JBA longtubes and 11+ Mustangs-Beware - Page 2 - Ford Mustang Forum
Reply
 
LinkBack Thread Tools
PONY Member
 
wproctor411's Avatar
 
Joined: Jan 2011
Location: Indianapolis
Posts: 277
 
Quote:
Originally Posted by strany View Post
I am an unfortunate soul who by trying to save a few $ bought LT headers that continually throw codes that no tuner Ive spoke with has a solution for. JBA has relocated the front O2 sensors rearward so far that my ECM tosses a ck engine light continually even after resetting it with my SCT tuner. JBA tech support has no answers as they appear uninformed about 11+ mustang tuning. Why would a manufacturer put out an aftermarket product without doing due the diligence of testing and modification so it functions properly with the car its designed to be bolted to?

Any ideas or solutions to my dilemna would be appreciated
Search your cel code and I bet the solution is to remove the front extensions but leaks and loose connectors throw codes on these cars too. Very sensitive electronics on the Yoda engines. There are threads on how to detach the harness from the top transmission bolt which you can see behind the engine from the passenger side, then wiggle the harness down. You just pull it off the bolt but its hard to reach without a lift. It worked for my BBK long tubes. Is your code a cat heater code? The cats are taking too long to heat up so at low idle your car probably runs real rich burning excess gas. Excessive Backfires? does it run fine at WOT? Do you smell the fuel? Do you have cats?


2011 5.0 GT 3.55 gears, Candy Apple, Steeda CAI and SCT Tune,Steeda Control Arms, LCA Relocation Bracket, Pan Hard Bar and Brace, Ultra Light Springs, 3rd Link, Camber Plates, Tokico D-Spec Struts/Shocks, Shifter, Barton Shifter Bushing, Flowmaster hush power. Steeda 18X9 Chrome Pentar/Nitto NT05 275/40/18. BBK long tubes and OR xpipe

2005 F150 SXT, OX Locker, 4.10 gears, Edge CS Tuner, 33x10 AT, K&N FIPK, Gibson Exhaust.
wproctor411 is offline  
Sponsored Links
Advertisement
 
MACH I Member
S197 Member
 
adspru's Avatar
 
Joined: Sep 2008
Location: Covered in Snow
Posts: 3,094
 
Quote:
Originally Posted by nsadams87xx View Post
That's interesting. Did he ever mention what he meant by "precautionary?"
You can PM me, but I'd rather not post it, I changed his informal words to "precautionary"...

Quote:
Originally Posted by tehMoose View Post
I can snap a pic when I get home in the morning. With the engine out I will be able to get a real good picture.
Any chance you could snap that pic bud??? Not certain as to why, but I just threw a P2626, O2 1 Bank 1 open circuit. Headed under Whitemare, I'll be practicing what grimace preaches "utilize the search box in the upper right hand corner". LMAO.

oh, and if anyone's hungry, rumor has it Peter is grilling up some venison steaks, I heard they were seared to perfection on the boss intake...



Some people lead the way blindly, Others follow with 20/20 vision

Aaron S.
2011 5.0| MT82| White/Saddle|HID|Brembo|3.73| GT/CS Fascia| Saleen Grill| DynaTech LT's and O/R X| AFCO Aluminum Radiator | J&M LCA's & RELO's|Hurst Billet + | Eibach Pro Springs| KONI STR-T |Bama93| Airaid| 255/40/19(f)285/35/19(r) Kuhmo ECSTA XS|

Gone but not forgotten
|08 Mustang GT, MT Black| 05 IS 300 MT Black| 00 Camaro SS MT Black|95 Acura Integra GSR MT Black | 91 Prelude Si 4WS MT Black|


Last edited by adspru; 10-13-2012 at 06:35 PM. Reason: P2626, not 2625
adspru is offline  
GT Member
 
JohnRichard's Avatar
 
Joined: Sep 2010
Location: Oklahoma City
Posts: 2,396
 
OP... That just bazar, I have a set of 1 7/8 on my 12 boss and the front o2 sensor is just in front of the collector, no issue as far as throwing codes... but with the rear o2 sensors it is a different story, unless I have the rears turned off even with using a none spark plug fouler about every 100 miles I get a p0420 and p0430 code and that has to do with the catalyst efficiency threshold…

Did you add the extensions? if so... take them off, you really don't need them for the front or the rear and try again.. I know all of the people that sale headers tell you, you need them… plus all of them are JUNK… you really don’t… Been there done that and had a pop tart after it was fixed



If this doesn't fix it then, from what you are telling…. It doesn’t matter what brand of after market headers your car runs it would get this code…
Welcome to the world of anomalies....

I don't speak often but when I do, I don't have clue what I am talking about. I just repeat things that I once heard and do not repeat them correctly... My doctor told me it was an ID 10 T problem and it was incurable.
So when I reply to a post or add to a thread I just find the words elsewhere and copy and paste.
JohnRichard is offline  
 
Grimace427
Guest
 
Grimace427's Avatar
 
Posts: n/a
Quote:
Originally Posted by adspru View Post
oh, and if anyone's hungry, rumor has it Peter is grilling up some venison steaks, I heard they were seared to perfection on the boss intake...

Nope. Bambi survived.



For now.





I'm searching home-made silencers for my AR15. Soon as I'm done I'm going huntin'. Cha-chick.:smoke:
MACH I Member
S197 Member
 
adspru's Avatar
 
Joined: Sep 2008
Location: Covered in Snow
Posts: 3,094
 
So I popped the black cap off the back of the block, got under the car and gently tugged and wouldn't you know, the extension came down on me already disconnected... Wonder how long it was off??? I assume it throw a code immediately... The little plastic lock on the clip was broken????

I think bambi got under my car and messed with my O2 wires. Then in a panic, ran like a deer to NoVa and hopped in front of grimace.


Some people lead the way blindly, Others follow with 20/20 vision

Aaron S.
2011 5.0| MT82| White/Saddle|HID|Brembo|3.73| GT/CS Fascia| Saleen Grill| DynaTech LT's and O/R X| AFCO Aluminum Radiator | J&M LCA's & RELO's|Hurst Billet + | Eibach Pro Springs| KONI STR-T |Bama93| Airaid| 255/40/19(f)285/35/19(r) Kuhmo ECSTA XS|

Gone but not forgotten
|08 Mustang GT, MT Black| 05 IS 300 MT Black| 00 Camaro SS MT Black|95 Acura Integra GSR MT Black | 91 Prelude Si 4WS MT Black|

adspru is offline  
Grimace427
Guest
 
Grimace427's Avatar
 
Posts: n/a
Quote:
Originally Posted by adspru View Post
So I popped the black cap off the back of the block, got under the car and gently tugged and wouldn't you know, the extension came down on me already disconnected... Wonder how long it was off??? I assume it throw a code immediately... The little plastic lock on the clip was broken????

I think bambi got under my car and messed with my O2 wires. Then in a panic, ran like a deer to NoVa and hopped in front of grimace.

Terry 'Beefcake' Reeves is the most high-profile person I know to blow their engine due to those harness extensions, so consider yourself lucky. Me on the other hand have a new insurance claim on a policy that is less than two weeks old. Sheesh.
MACH I Member
S197 Member
 
adspru's Avatar
 
Joined: Sep 2008
Location: Covered in Snow
Posts: 3,094
 
At least your policy was in effect, and paid up to date, things could be much worse, when I saw the cel, I had visions of sugarplums dancing through my head, ahemmmm, 8 of them, and the last one fell on its face


Some people lead the way blindly, Others follow with 20/20 vision

Aaron S.
2011 5.0| MT82| White/Saddle|HID|Brembo|3.73| GT/CS Fascia| Saleen Grill| DynaTech LT's and O/R X| AFCO Aluminum Radiator | J&M LCA's & RELO's|Hurst Billet + | Eibach Pro Springs| KONI STR-T |Bama93| Airaid| 255/40/19(f)285/35/19(r) Kuhmo ECSTA XS|

Gone but not forgotten
|08 Mustang GT, MT Black| 05 IS 300 MT Black| 00 Camaro SS MT Black|95 Acura Integra GSR MT Black | 91 Prelude Si 4WS MT Black|

adspru is offline  
Grimace427
Guest
 
Grimace427's Avatar
 
Posts: n/a
Quote:
Originally Posted by adspru View Post
At least your policy was in effect, and paid up to date, things could be much worse, when I saw the cel, I had visions of sugarplums dancing through my head, ahemmmm, 8 of them, and the last one fell on its face

Too bad it didn't have one of those 'cooling pads' to keep it ship shape!
Apprentice
 
1st RoadRage's Avatar
 
Joined: Jun 2012
Location: Midlothian
Posts: 217
 
I may be a old fuddy duddy, but isn't anyone the least bit concerned about their costly engines having to be fooled/tweaked/hypnotized/drugged/ironmanned into behaving properly? And the poster is quite right that 49-state legal is a joke - show us the certification, mfrs. :kooky:

2011 GT Premium Brembo ("Spirit"), Kona/red, 1.5" drop, Goodridge SS brake lines, 3.73's, LPW Ultra diff cover, HID, JLT oil catch can, FRPP ProCal II w. Airaid, FRPP X-pipe, Roush axlebacks, Boss LS tranny cooler, Boss oil cooler, Boss radiator, Torsen T2-R; FRPP "K" springs, struts, shocks, mounts, anti-rollbars, upper strut brace, poly bushings; Barton shifter/MkII bracket, CG-Lock, Grabber knob, silver Forgestar CF5 19x9 35mm offset, AE aluminum driveshaft
1st RoadRage is offline  
Grimace427
Guest
 
Grimace427's Avatar
 
Posts: n/a
Quote:
Originally Posted by 1st RoadRage View Post
I may be a old fuddy duddy, but isn't anyone the least bit concerned about their costly engines having to be fooled/tweaked/hypnotized/drugged/ironmanned into behaving properly? And the poster is quite right that 49-state legal is a joke - show us the certification, mfrs. :kooky:

What do you mean by behaving properly? What is the 'fooling' going on here?
MACH I Member
S197 Member
 
adspru's Avatar
 
Joined: Sep 2008
Location: Covered in Snow
Posts: 3,094
 
Quote:
Originally Posted by 1st RoadRage View Post
I may be a old fuddy duddy, but isn't anyone the least bit concerned about their costly engines having to be fooled/tweaked/hypnotized/drugged/ironmanned into behaving properly? And the poster is quite right that 49-state legal is a joke - show us the certification, mfrs. :kooky:
Are you concerned that your costly motor has been tweaked????


Some people lead the way blindly, Others follow with 20/20 vision

Aaron S.
2011 5.0| MT82| White/Saddle|HID|Brembo|3.73| GT/CS Fascia| Saleen Grill| DynaTech LT's and O/R X| AFCO Aluminum Radiator | J&M LCA's & RELO's|Hurst Billet + | Eibach Pro Springs| KONI STR-T |Bama93| Airaid| 255/40/19(f)285/35/19(r) Kuhmo ECSTA XS|

Gone but not forgotten
|08 Mustang GT, MT Black| 05 IS 300 MT Black| 00 Camaro SS MT Black|95 Acura Integra GSR MT Black | 91 Prelude Si 4WS MT Black|

adspru is offline  
Apprentice
 
2011 GT 4 ME's Avatar
 
Joined: Mar 2012
Location: Santee
Posts: 233
 
Quote:
Originally Posted by strany View Post
I am an unfortunate soul who by trying to save a few $ bought LT headers that continually throw codes that no tuner Ive spoke with has a solution for. JBA has relocated the front O2 sensors rearward so far that my ECM tosses a ck engine light continually even after resetting it with my SCT tuner. JBA tech support has no answers as they appear uninformed about 11+ mustang tuning. Why would a manufacturer put out an aftermarket product without doing due the diligence of testing and modification so it functions properly with the car its designed to be bolted to?

Any ideas or solutions to my dilemna would be appreciated

Get with a custom tuner and they can take care of this right away.
2011 GT 4 ME is offline  
Apprentice
 
2011 GT 4 ME's Avatar
 
Joined: Mar 2012
Location: Santee
Posts: 233
 
Quote:
Originally Posted by strany View Post
I am an unfortunate soul who by trying to save a few $ bought LT headers that continually throw codes that no tuner Ive spoke with has a solution for. JBA has relocated the front O2 sensors rearward so far that my ECM tosses a ck engine light continually even after resetting it with my SCT tuner. JBA tech support has no answers as they appear uninformed about 11+ mustang tuning. Why would a manufacturer put out an aftermarket product without doing due the diligence of testing and modification so it functions properly with the car its designed to be bolted to?

Any ideas or solutions to my dilemna would be appreciated
This is not an issue with JBA Headers and for you to think it is shows you should do more research and learn about mods for your car before ordering parts.. ALL long tube headers will through a code if you don't custom tune them. It might happen in 25 miles or 500 but it will happen. This is a VERY easy fix and can be taken care of by any tuner in the US.
2011 GT 4 ME is offline  
Grimace427
Guest
 
Grimace427's Avatar
 
Posts: n/a
Quote:
Originally Posted by 2011 GT 4 ME View Post
This is not an issue with JBA Headers and for you to think it is shows you should do more research and learn about mods for your car before ordering parts.. ALL long tube headers will through a code if you don't custom tune them. It might happen in 25 miles or 500 but it will happen. This is a VERY easy fix and can be taken care of by any tuner in the US.

Just to clarify your post in simpler terms, a 'custom' tune is not required. Just turning off the rear O2 sensors is all that is necessary.
MACH I Member
S197 Member
 
adspru's Avatar
 
Joined: Sep 2008
Location: Covered in Snow
Posts: 3,094
 
Muhahha, P2626 has reared it's ugly face again, with extensions removed.... Lucky me, I was datalogging normal driving at the time, and nothing looks odd on that file??? I sent it off to Mike W, waiting to see what he says, Ill update this hijacked thread.



Some people lead the way blindly, Others follow with 20/20 vision

Aaron S.
2011 5.0| MT82| White/Saddle|HID|Brembo|3.73| GT/CS Fascia| Saleen Grill| DynaTech LT's and O/R X| AFCO Aluminum Radiator | J&M LCA's & RELO's|Hurst Billet + | Eibach Pro Springs| KONI STR-T |Bama93| Airaid| 255/40/19(f)285/35/19(r) Kuhmo ECSTA XS|

Gone but not forgotten
|08 Mustang GT, MT Black| 05 IS 300 MT Black| 00 Camaro SS MT Black|95 Acura Integra GSR MT Black | 91 Prelude Si 4WS MT Black|

adspru is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1