Please help diagnose aftermarket suspension noises in 2012 Mustang - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 10-22-2012 Thread Starter
PONY Member
5.0L Member
S197 Member
 
enjracing's Avatar
 
Joined: Jun 2012
Location: mooresville
Posts: 450
 
Exclamation Please help diagnose aftermarket suspension noises in 2012 Mustang

hey guys, so you can see in my sig, all of the suspension mods that i have. all bushings are urethane and not hiem or delrin, just fyi.

ok, lets say that i am very slowly going over some steep speed bumps...i get a noise that very much sounds like bushing noise. it's not sqeek, it's more like that sound when rubber is being stretched/rubbing against something. all my urethane bushings have been heavily greased with prothane bushing grease, so unless i missed a spot where a bushing is touching some metal, i can't figure that that is where the noise is coming from. i have also checked that everything is tight as well.

now, here is what i did notice...it wasn't until i installed my upper non-adjustable control arms, that i heard this noise. the stock bushing on the axle is still in place. maybe i didn't grease the chassis end of that UCA bushing well enough? or maybe the stock axle bushing is binding and causing this noise? idk.

here is one thing that i did notice though and it must be do to being under load....i do not get this noise when i go over bumps, if i am accelerating. even if the acceleration is minor, i don't get the noise. only off throttle or if i'm braking while going over bumps.

any ideas and input is appreciated guys. thanks.


2012 Black/black GT Premium, Brembo, HID, 3.73 - Borla LT's, Borla x-pipe, Borla touring cat back, Airraid CAI, Bama 93R tune, Steeda LCA/UCA, MM CC plates, panhard and bracket, front/rear swaybars, billet front/rear swaybar brackets/links, chassis brace, Bump steer kit, Tri-Ax shifter/bracket,Eibach Multi-Pro R2 CO's, FRPP diff cover, Weds Wheels 19x10, 275/40/19 Bridgestone Pole Position, GT500 rear spoiler, CDC chin spoiler. Full stereo system.
enjracing is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-22-2012
PONY Member
 
vSPARXv's Avatar
 
Joined: Dec 2010
Location: Houston
Posts: 724
 
i believe there is a recall or TSB for that issue. something about a creaking noise going over bumps... might want to google it


12' RR GT | FORD RACING | JBA | CERVINI | ROUSH | KONI | H&R | 3DCARBON | C&L | AMRs | BREMBO | CDC
vSPARXv is offline  
post #3 of 10 (permalink) Old 10-22-2012 Thread Starter
PONY Member
5.0L Member
S197 Member
 
enjracing's Avatar
 
Joined: Jun 2012
Location: mooresville
Posts: 450
 
Quote:
Originally Posted by vSPARXv View Post
i believe there is a recall or TSB for that issue. something about a creaking noise going over bumps... might want to google it
i will thanks, but it's from the mods i did for sure. car made no noises in the rear suspension when it was stock lol.

2012 Black/black GT Premium, Brembo, HID, 3.73 - Borla LT's, Borla x-pipe, Borla touring cat back, Airraid CAI, Bama 93R tune, Steeda LCA/UCA, MM CC plates, panhard and bracket, front/rear swaybars, billet front/rear swaybar brackets/links, chassis brace, Bump steer kit, Tri-Ax shifter/bracket,Eibach Multi-Pro R2 CO's, FRPP diff cover, Weds Wheels 19x10, 275/40/19 Bridgestone Pole Position, GT500 rear spoiler, CDC chin spoiler. Full stereo system.
enjracing is offline  
 
post #4 of 10 (permalink) Old 10-22-2012
Grimace427
Guest
 
Grimace427's Avatar
 
Posts: n/a
I can't recommend this stuff enough. Everyone should be using this grease for any kind of polyurethane bushing install.

polyurethane lube

I fought squeaky bushings for over a year, tried multiple professional-grade bushing greases and lubes and nothing lasted for more than a month. I put this stuff on early 2012 maybe even 2011(can't remember) and not a single peep since.

Note, this stuff goes on the outside of the bushings and not in the zerk fittings.
post #5 of 10 (permalink) Old 10-22-2012
SHELBY GT 350 Member
4.6L Member
 
racin366's Avatar
 
Joined: May 2008
Location: Pompano Beach
Posts: 5,329
 
First thing that comes to mind is the sway bar pivots, I would check them and make sure they are lubed well, if not they will sound exactly like what you describe.

The artist formerly known as SteedaMatt.
racin366 is offline  
post #6 of 10 (permalink) Old 10-22-2012 Thread Starter
PONY Member
5.0L Member
S197 Member
 
enjracing's Avatar
 
Joined: Jun 2012
Location: mooresville
Posts: 450
 
Quote:
Originally Posted by Grimace427 View Post
I can't recommend this stuff enough. Everyone should be using this grease for any kind of polyurethane bushing install.

polyurethane lube

I fought squeaky bushings for over a year, tried multiple professional-grade bushing greases and lubes and nothing lasted for more than a month. I put this stuff on early 2012 maybe even 2011(can't remember) and not a single peep since.

Note, this stuff goes on the outside of the bushings and not in the zerk fittings.
really? wow. that would be awesome, but the thought of unbolting everything again sux! but....so does the squeek.

2012 Black/black GT Premium, Brembo, HID, 3.73 - Borla LT's, Borla x-pipe, Borla touring cat back, Airraid CAI, Bama 93R tune, Steeda LCA/UCA, MM CC plates, panhard and bracket, front/rear swaybars, billet front/rear swaybar brackets/links, chassis brace, Bump steer kit, Tri-Ax shifter/bracket,Eibach Multi-Pro R2 CO's, FRPP diff cover, Weds Wheels 19x10, 275/40/19 Bridgestone Pole Position, GT500 rear spoiler, CDC chin spoiler. Full stereo system.
enjracing is offline  
post #7 of 10 (permalink) Old 10-22-2012 Thread Starter
PONY Member
5.0L Member
S197 Member
 
enjracing's Avatar
 
Joined: Jun 2012
Location: mooresville
Posts: 450
 
Quote:
Originally Posted by racin366 View Post
First thing that comes to mind is the sway bar pivots, I would check them and make sure they are lubed well, if not they will sound exactly like what you describe.
good thought, but greased the **** outta those too. it's gotta be either the UCA OE axle bushing or maybe what the other guy said about needing that better bushing lube all over the car.

2012 Black/black GT Premium, Brembo, HID, 3.73 - Borla LT's, Borla x-pipe, Borla touring cat back, Airraid CAI, Bama 93R tune, Steeda LCA/UCA, MM CC plates, panhard and bracket, front/rear swaybars, billet front/rear swaybar brackets/links, chassis brace, Bump steer kit, Tri-Ax shifter/bracket,Eibach Multi-Pro R2 CO's, FRPP diff cover, Weds Wheels 19x10, 275/40/19 Bridgestone Pole Position, GT500 rear spoiler, CDC chin spoiler. Full stereo system.
enjracing is offline  
post #8 of 10 (permalink) Old 10-23-2012
J Orbit
Guest
 
J Orbit's Avatar
 
Posts: n/a
I too know the pain of polyurethane. My car squeaks and thunks about no matter how tight or greasd up it is. I just figure the more suspension mods you do the closer it is to being a race car and some race cars sound like they're falling apart even when they're working perfectly.

I know I could go and disassemble everything and wrap some teflon tape and use Grim's lube but that sounds like a PITA so I just deal with the noise. If the bushings wear out in 30k miles instead of 50k I won't be upset..
post #9 of 10 (permalink) Old 10-25-2012
Apprentice
5.0L Member
 
Wrext's Avatar
 
Joined: Dec 2011
Location: Waterdown
Posts: 212
 
Quote:
Originally Posted by enjracing View Post
hey guys, so you can see in my sig, all of the suspension mods that i have. all bushings are urethane and not hiem or delrin, just fyi.

ok, lets say that i am very slowly going over some steep speed bumps...i get a noise that very much sounds like bushing noise. it's not sqeek, it's more like that sound when rubber is being stretched/rubbing against something. all my urethane bushings have been heavily greased with prothane bushing grease, so unless i missed a spot where a bushing is touching some metal, i can't figure that that is where the noise is coming from. i have also checked that everything is tight as well.

now, here is what i did notice...it wasn't until i installed my upper non-adjustable control arms, that i heard this noise. the stock bushing on the axle is still in place. maybe i didn't grease the chassis end of that UCA bushing well enough? or maybe the stock axle bushing is binding and causing this noise? idk.

here is one thing that i did notice though and it must be do to being under load....i do not get this noise when i go over bumps, if i am accelerating. even if the acceleration is minor, i don't get the noise. only off throttle or if i'm braking while going over bumps.

any ideas and input is appreciated guys. thanks.
whoa, similar car and mods to mine! Are your tires the S0-4's? How do you like them?

2012 Mustang GT, Lava Red Metallic, Brembo, 401A, Cashmere leather, pedestal spoiler and hoodscoop. Mods - Boss shift knob, Weathertechs, GT fender badges, Steeda Ultra-lites/Tokico's D-specs/Steeda HD mounts & phb/GT500 iso's, 20% tint, Steeda UCA, Roush Axlebacks, Bassani X-pipe, no reso's, Painted lower valances, Boss mudflaps, MMD hood struts, MGW shifter, 275/40R19 Michelin Super Sports all around, Whiteline Sways/LCA's/Brackets, Steeda CAI, Bama 93 tune.
Wrext is offline  
PONY Member
 
wproctor411's Avatar
 
Joined: Jan 2011
Location: Indianapolis
Posts: 277
 
We pretty much havethesame setup. I've read on here where people say do not exceed the recommended torque. Too tight can cause binding noses. Did you replace the upper control arm bracket that attaches to the body? Brenspeed recommended I do this to eliminate/prevent noise from the UCA but I never had a noise issue.

Of all things check the torque on your shocks and struts too. I had to retorque mine after 500 miles...which is recommended for almost anything.

Maybe some debris was in the grease ?

My 2 cents.

2011 5.0 GT 3.55 gears, Candy Apple, Steeda CAI and SCT Tune,Steeda Control Arms, LCA Relocation Bracket, Pan Hard Bar and Brace, Ultra Light Springs, 3rd Link, Camber Plates, Tokico D-Spec Struts/Shocks, Shifter, Barton Shifter Bushing, Flowmaster hush power. Steeda 18X9 Chrome Pentar/Nitto NT05 275/40/18. BBK long tubes and OR xpipe

2005 F150 SXT, OX Locker, 4.10 gears, Edge CS Tuner, 33x10 AT, K&N FIPK, Gibson Exhaust.
wproctor411 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1