2014 GT stumble at idle - should I be concerned? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 01-18-2016 Thread Starter
Rookie
 
TheJMan48's Avatar
 
Joined: Apr 2014
Location: Anthem, AZ
Posts: 41
 
2014 GT stumble at idle - should I be concerned?

I've got a 2014 GT with about 22K miles on it that for awhile now has had a stumble at idle that is most noticeable when the engine is warm. It hasn't set off the CEL, the throttle response is still good and the car otherwise drives normally. It doesn't sound like a traditional misfire where you can audibly hear a pop and feel the car shake, it's more of a "pfft" sound.

Is this something that I should be concerned about? I've run a can of Techron fuel system cleaner but it didn't change anything. Car is stock aside from Roush axleback and Pypes after-cat X-pipe.

TheJMan48 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-18-2016
GLOBAL MODERATOR
S197 Member
 
5.0 Coyote's Avatar
 
Joined: Oct 2010
Location: San Carlos Park
Posts: 2,330
               
If that was my Mustang,I would have it checked out,it is not running like it should.

5.0 Coyote is offline  
post #3 of 6 (permalink) Old 01-25-2016
SHELBY GT 350 Member
 
2oo5GT's Avatar
 
Joined: Nov 2007
Location: Valdosta
Posts: 5,089
 
Pull the plugs and see how they look. I had a slight stumble and changed the plugs. No more stumble. Mine has 28K miles.

2014 Mustang GT, A6, Grabber Blue
2oo5GT is offline  
 
post #4 of 6 (permalink) Old 01-26-2016 Thread Starter
Rookie
 
TheJMan48's Avatar
 
Joined: Apr 2014
Location: Anthem, AZ
Posts: 41
 
I actually parked the car today for a few hours on an angle facing slightly downward and when I started the car it seemed to be misfiring/stumbling much more than normal. However, once I started rolling it seemed to clear itself and drove normally. Still doesn't trip the check engine light, and under load is perfectly normal. I'll pull the plugs and see what they look like.
TheJMan48 is offline  
post #5 of 6 (permalink) Old 01-26-2016
PONY Member
 
scott9050's Avatar
 
Joined: Nov 2013
Location: Martinsburg
Posts: 419
 
My off idle stumble was caused by a dirty throttle body. As soon as I removed and cleaned it it ran like new.

2014 Sterling gray GT 6M
Paxton Novi 2200 with torque booser and Lund tune, DW1000 injectors, JMS BAP, ATI damper
Lethal ORP, MGW shifter, BMR upper and lowers, Spicer 1 piece DS, Ram Single disk clutch with aluminum flywheel, Power leather seat conversion. Staggered wheels.
scott9050 is offline  
post #6 of 6 (permalink) Old 01-26-2016
PONY Member
 
LosAngelesGT's Avatar
 
Joined: Aug 2011
Location: Los Angeles
Posts: 473
 
Check the coil over plugs as well as the spark plugs. That was my problem

2001 Mustang GT - Crashed (Other person's fault) Stock.
2003 Mustang GT - Sold
Lowered, Flowmaster catbacks, CAI + Tune, 5% tint all around, American racing wheels.
2005 Mustang GT - Traded in
"Performance" spark plugs and ignition coils, 5% tint on back 3 - 20% on front two, 20 inch silver AMR wheels
2011 Mustang GT - BEAST
5% tint all around. 2014 GT premium wheels. Roush axleback
LosAngelesGT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1