2014 Mustang PCM Removal - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-17-2016 Thread Starter
Rookie
 
mlbdevil's Avatar
 
Joined: Mar 2016
Posts: 5
 
2014 Mustang PCM Removal

I have to remove my PCM and send it to SCT in order to get my car running again. I am having a hell of a time finding instructions on how to remove this. Any ideas?


2014 Mustang GT 5.0 - 275/40 ZR19, 245/45 ZR19, SCT Livewire TS, Eibach Sportline Springs, Borla Over-Axle Pipes, Pypes O/R H-Pipe
mlbdevil is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-17-2016
GT Member
 
PMDmustang13's Avatar
 
Joined: Jun 2012
Location: Omaha
Posts: 1,649
 
Maybe try looking in the 2011 service manual on this forum.


2013 GT, Track Pack, Recaros, Kooks Axlebacks, Airaid CAI, BMR Rear Adj. LCAs, BMR Relocation Brackets, JLT Oil Separator(s), Barton 2 Post Shifter Bracket, Steeda Motor Mounts, Barton Shifter, JHR Clutch line, BMR adj. UCA and Mount, Kooks 1 3/4 headers/catted H, DSS Al Shaft, BMR Loop, Vogtland Sport Springs front/BMR rear, Strange Adj. Struts/Shocks, Extended ball joints, Steeda Bumpsteer Kit, Whiteline Tranny Mount Bushing, Borla Overaxles, BMR Watts, Vorshlag 3" Ducts
PMDmustang13 is offline  
post #3 of 5 (permalink) Old 03-17-2016 Thread Starter
Rookie
 
mlbdevil's Avatar
 
Joined: Mar 2016
Posts: 5
 
nevermind, two bolts later and detached the 3 ecu plugs.
All set.

2014 Mustang GT 5.0 - 275/40 ZR19, 245/45 ZR19, SCT Livewire TS, Eibach Sportline Springs, Borla Over-Axle Pipes, Pypes O/R H-Pipe
mlbdevil is offline  
 
post #4 of 5 (permalink) Old 05-13-2016
Rookie
 
Mrbigdickwillis's Avatar
 
Joined: May 2016
Posts: 1
 
I'm in the same situation I have to send my PCM to SCT because my car doesn't start. it threw error code #110D8 on my X4 tuner
Mrbigdickwillis is offline  
post #5 of 5 (permalink) Old 05-13-2016
PONY Member
 
daustin's Avatar
 
Joined: Apr 2012
Location: Las Vegas
Posts: 768
 
Garage
Quote:
Originally Posted by Mrbigdickwillis View Post
I'm in the same situation I have to send my PCM to SCT because my car doesn't start. it threw error code #110D8 on my X4 tuner

Try disconnecting your battery for 20-30 minutes with the light switch in the on position. Reconnect your battery, turn lights and everything back off, hook the battery up to a tender or charger and try again. This worked for me back in December.

2016 Mustang GT 401a, 6A, Magnetic Metallic, Nav, Shaker Pro, 20" SVE Series 3's, Steeda CAI, Corsa Sports, BMR SP080 Springs, BMR Caster/Camber Plates, JLT Catch Can, Redline Hood Struts.....

2014 Mustang GT 400a, 6M, Recaros, 3.73's, 19" Drifts, electronics/nav., Kooks A/B's, AED Tune /Steeda CAI/BBQ Igniter Tick... SOLD
daustin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1