Front corner marker lights damaged - Ford Mustang Forum
Like Tree2Likes
  • 1 Post By Strange Mud
  • 1 Post By Strange Mud
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 06-15-2017 Thread Starter
PONY Member
 
DerekStangGT's Avatar
 
Joined: Mar 2012
Location: Austin
Posts: 424
 
Front corner marker lights damaged

Hello! Long time no see, AFM! Took a bit of a sabatical to pursue other (cheaper) hobbies, but now I'm back!

So I recently replaced my headlights with a better set of projectors. When I went to pull the front bumper off, I accidentally ripped both front corner light connectors out, instead of being able to nicely press on the connector and pull them out. When I went to re-connect the corner markers, neither would click back in. There is no visible damage to the male or female connectors, but there is noticeable resistance inside the plugs. I tried using a bit of force but that didn't work. I tried using a small screwdriver and adjusting the angles of the prongs inside the connector, but that didnt work either. Has anyone had experience with this, or know what the issue could be? I buttoned everything back up without the corner markers, but I really need to have them working again, I believe it's a safety inspection issue.


2012 Grabber Blue Mustang GT MT82 - 401A, Brembos, 3.73s, Reverse Sensors/Security System, GT500 Axle Backs, Raxiom Projectors with 5k HIDs, Eibach Pro-Kit, Koni STR.Ts, Ford Racing Strut Mounts, Eibach Camber Bolts, BFG G-Force Sport Comp 2s 275/35/19

Awaiting Install: JHR Shifter Bracket
DerekStangGT is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-15-2017
SHELBY GT 350 Member
 
Strange Mud's Avatar
 
Joined: Apr 2011
Location: small town CT
Posts: 5,387
         
some of these h2o proof connectors are real tight. triple check it's straight with no damage/ orientation correct/ maybe a touch of Vaseline/die-electrical grease and go for it.

5.0 Coyote likes this.

2012 V6 traded in for a 2017 VW GTI.
Strange Mud is offline  
post #3 of 7 (permalink) Old 06-15-2017 Thread Starter
PONY Member
 
DerekStangGT's Avatar
 
Joined: Mar 2012
Location: Austin
Posts: 424
 
Quote:
Originally Posted by Strange Mud View Post
some of these h2o proof connectors are real tight. triple check it's straight with no damage/ orientation correct/ maybe a touch of Vaseline/die-electrical grease and go for it.
I'll check again, but I was using almost all my strength to try to get the connector to click back in, and I'm a big guy. It only slides in one way as it has the protrusion on top so it isn't an alignment issue.

2012 Grabber Blue Mustang GT MT82 - 401A, Brembos, 3.73s, Reverse Sensors/Security System, GT500 Axle Backs, Raxiom Projectors with 5k HIDs, Eibach Pro-Kit, Koni STR.Ts, Ford Racing Strut Mounts, Eibach Camber Bolts, BFG G-Force Sport Comp 2s 275/35/19

Awaiting Install: JHR Shifter Bracket
DerekStangGT is offline  
 
post #4 of 7 (permalink) Old 06-15-2017
GT Member
 
dusman59's Avatar
 
Joined: Oct 2010
Location: Mesa
Posts: 1,185
 
If the connectors do end up broken you could use RTV sealant to hold them together. If you need to take it apart again RTV will not harden like glue.


2011 Red Candy /build 2/1/11/ 401A
MT with Redline MTL/ Brembos/355's/glass roof
Shaker 1000/Scoops/Clear bra/Steeda UCA and PH bar
Redline hood lifts/Bilsteins with Ford Racing P springs & axle bks
UPR catch can/whiteline kdt928/MGW shifter with Epco ball
Shaftmasters DS/BMR loop & relocation brackets
Nitto 555 G2's/Steeda jack rails
dusman59 is offline  
post #5 of 7 (permalink) Old 06-16-2017
SHELBY GT 350 Member
 
Strange Mud's Avatar
 
Joined: Apr 2011
Location: small town CT
Posts: 5,387
         
I've used Channel-locs to put connectors back together.

I'm sure it ain't reccomended....but that is what I've had to do.
5.0 Coyote likes this.

2012 V6 traded in for a 2017 VW GTI.
Strange Mud is offline  
post #6 of 7 (permalink) Old 06-16-2017 Thread Starter
PONY Member
 
DerekStangGT's Avatar
 
Joined: Mar 2012
Location: Austin
Posts: 424
 
Quote:
Originally Posted by Strange Mud View Post
I've used Channel-locs to put connectors back together.

I'm sure it ain't reccomended....but that is what I've had to do.
Ok, I'll try that!

2012 Grabber Blue Mustang GT MT82 - 401A, Brembos, 3.73s, Reverse Sensors/Security System, GT500 Axle Backs, Raxiom Projectors with 5k HIDs, Eibach Pro-Kit, Koni STR.Ts, Ford Racing Strut Mounts, Eibach Camber Bolts, BFG G-Force Sport Comp 2s 275/35/19

Awaiting Install: JHR Shifter Bracket
DerekStangGT is offline  
post #7 of 7 (permalink) Old 06-21-2017
Site Sponsor
 
Diode Dynamics's Avatar
 
Joined: Dec 2012
Location: Saint Louis
Posts: 963
 
Might as well upgrade IMO:



HID and LED Lighting For Your Mustang
Visit diodedynamics.com To See Products!
(314) 205-3033
Diode Dynamics is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1