Squeaky Suspensions - Ford Mustang Forum
Reply
 
LinkBack Thread Tools
post #1 of 58 (permalink) Old 08-11-2011 Thread Starter
Apprentice
 
babanist's Avatar
 
Joined: Mar 2011
Location: Dubai
Posts: 130
 
Exclamation Squeaky Suspensions

Hello guys...
I came across something i found a bit strange yesterday while driving around before dinner... I've had my baby for almost 2 weeks now (2012 GT Convertible - AUTO), been very happy with how she runs so yesterday i was cruising around before dinner (was a bit early for a dinner invitation so decided to cruise around and kill time)

While cruising i starting hearing some noises but wasnt sure where its coming from...kept driving but paid more attention to that strange new sound im hearing...after few minutes it was clear that the sound was coming from the front end of the car in a form of a "TICK" when i put my foot on the throttle even if gently. I had to go over a speed hump (slowly obviously) and thats when i heard squeaking noise coming from the suspensions...and now there were 2 ticks coming from the front end when i accelerate. I think the ticks were coming from the suspensions too.

It was very close to the dinner invitation time so decided to go where the invitation is and worry about the car after that.

I came back after dinner, all i was thinking about is that noise i heard. I started driving but i heard no ticks, i went over a couple of speed humps with no squeaks and kept on driving around for a while with nothing at all!!

Now of course i was happy that those noises disappeared but i am still curious what could have caused them? and if anyone had the same thing happen to them?

Sorry for the long story!!

babanist is offline  
Sponsored Links
Advertisement
 
post #2 of 58 (permalink) Old 08-11-2011
PONY Member
 
BK2BLKGT's Avatar
 
Joined: Nov 2008
Location: Pearl City
Posts: 453
 
Send a message via AIM to BK2BLKGT Send a message via Yahoo to BK2BLKGT
Sounds like you might be one of the ones with the faulty front LCA's (lower control arms). From what you are experiencing, i would take it into your dealership and have service get the TSB 110708 and check it out. Possibly have worn out bearings from factory..just a guess.


Barton w/Bracket-Koni Sports w/Steeda Sport springs - Steeda HD mounts - BMR adj PH bar-Whiteline adj LCA's w/brackets - Whiteline front/rear adj sway bars - DSS Carbon driveshaft - Whipple 2.9L w/ JLT Super Big air - JBA Ceramic long tubes w/ O/R x pipe-Magnaflow Competition Catback - RTR's with Conti Extreme Contact DW's 275/40 19 front & Nitto 305 rear - Lund Tuned
BK2BLKGT is offline  
post #3 of 58 (permalink) Old 08-11-2011 Thread Starter
Apprentice
 
babanist's Avatar
 
Joined: Mar 2011
Location: Dubai
Posts: 130
 
Wouldnt the sound stay and keep coming back if this was the case?
babanist is offline  
 
post #4 of 58 (permalink) Old 08-11-2011
PONY Member
 
BK2BLKGT's Avatar
 
Joined: Nov 2008
Location: Pearl City
Posts: 453
 
Send a message via AIM to BK2BLKGT Send a message via Yahoo to BK2BLKGT
should be the case but its an idea, also sounds like it might be something that happens after the car has been running a bit and warmed up. Could be anything really, but if you were hearing two ticks, coulda been both driver/passenger side LCA's. Worth getting it looked at since there is a TSB on it. I have no idea on what else it could be.

Barton w/Bracket-Koni Sports w/Steeda Sport springs - Steeda HD mounts - BMR adj PH bar-Whiteline adj LCA's w/brackets - Whiteline front/rear adj sway bars - DSS Carbon driveshaft - Whipple 2.9L w/ JLT Super Big air - JBA Ceramic long tubes w/ O/R x pipe-Magnaflow Competition Catback - RTR's with Conti Extreme Contact DW's 275/40 19 front & Nitto 305 rear - Lund Tuned
BK2BLKGT is offline  
post #5 of 58 (permalink) Old 08-11-2011
Apprentice
4.6L Member
 
tycat947's Avatar
 
Joined: Jan 2011
Location: Norman
Posts: 210
 
Garage
Quote:
Originally Posted by babanist View Post
Hello guys...
I came across something i found a bit strange yesterday while driving around before dinner... I've had my baby for almost 2 weeks now (2012 GT Convertible - AUTO), been very happy with how she runs so yesterday i was cruising around before dinner (was a bit early for a dinner invitation so decided to cruise around and kill time)

While cruising i starting hearing some noises but wasnt sure where its coming from...kept driving but paid more attention to that strange new sound im hearing...after few minutes it was clear that the sound was coming from the front end of the car in a form of a "TICK" when i put my foot on the throttle even if gently. I had to go over a speed hump (slowly obviously) and thats when i heard squeaking noise coming from the suspensions...and now there were 2 ticks coming from the front end when i accelerate. I think the ticks were coming from the suspensions too.

It was very close to the dinner invitation time so decided to go where the invitation is and worry about the car after that.

I came back after dinner, all i was thinking about is that noise i heard. I started driving but i heard no ticks, i went over a couple of speed humps with no squeaks and kept on driving around for a while with nothing at all!!

Now of course i was happy that those noises disappeared but i am still curious what could have caused them? and if anyone had the same thing happen to them?

Sorry for the long story!!
I have 3 or 4 speed bumps in my subdivision and it wasn't too long after picking up my 2012 GT convertible that I noticed the front suspension noises when going over the bumps. I'd read about the problem on here before mine had come in so was prepared. I haven't noticed any 'tick' though. Mine doesn't make the noise all the time though. When it does squeak it's really annoying but the last couple of days, there is nothing when going over the speed bumps. I also had read that the problem with the LCA's had been rectified before mine was built so not sure what's up. Was going to give it a while before taking it in so I guess I will do something soon.

2012 GT Premium Convertible, 401A, Ingot Silver, Brick Red/Cashmere Leather, Auto, HID, Security, Electronics Pkg, Comfort, Rear Camera.....
tycat947 is offline  
post #6 of 58 (permalink) Old 08-11-2011 Thread Starter
Apprentice
 
babanist's Avatar
 
Joined: Mar 2011
Location: Dubai
Posts: 130
 
Yeah i am planning to take it if the sound comes back, if it doesnt which im hoping for, i will tell them about it when its due for service.

It could be due to something heating up too but i wonder what that could be, i was driving for about 90 minutes between highways and city with different speeds and revs so could be anything. Wanted to know if anyone had this case before.

I dont think its serious but wud like it fixed
babanist is offline  
post #7 of 58 (permalink) Old 08-11-2011
PONY Member
 
socasam's Avatar
 
Joined: Nov 2009
Location: OKC
Posts: 434
 
Garage
Me and my roommate both have 2012 v6's and they both were making a clunky/creaky noise up front. We both took them in and they replaced the LCA's on mine and just tightened the sway bar on his. From what you described I am sure it is one of these issues. Just take it to the dealer and let them worry about it.

2012 Performance white/saddle premium 6mt 5.0 with HID's, Reverse sensing, Reverse camera, comfort package, 3.73's, black billet upper/lower grille, smoked headlight covers, Pypes black AB's, Eleanor style louvers, Eibach pro kit springs, PP wheels, 19" nickel painted (winter) wheels WeatherTech floor liners, infinity kappa 682.9cf front speakers..
TRADED -2012 Lava Red Metallic v6 Premium:
Mustang Club of America, Performance package, HIDs, Reverse Sensor/Security package, Comfort Package...
socasam is offline  
post #8 of 58 (permalink) Old 08-12-2011
GT Member
 
Elite_Deforce's Avatar
 
Joined: Dec 2010
Location: Montreal
Posts: 2,492
 
I have the LCA issue too. Planning on taking it in soon.

-2012 Grabber Blue GT 6M Premium w/ Brembos, Glass Roof, HID security pkg, Rear Camera, 401a, FRPP GT500 Axle-backs, Front Pioneer TS-D6802R speakers, JHR bracket, Bondra clutch extension.
-1986 Mazda RX-7 GX - Fast Mirage 16" Wheels, Sumo Firenza 205/60R Tires, slotted brakes + performance pads. Otherwise factory stock.
-2008 Mazda Mazda3 GT Sport - Stock, 5MT.
-2004 Volvo XC90 T5 - Comfort pkg, safety pkg.
-1995 Infiniti G20 - Sold, Pioneer head unit, lighting mods, miss it dearly.
Elite_Deforce is offline  
post #9 of 58 (permalink) Old 08-12-2011
Apprentice
 
HarrishMasher's Avatar
 
Joined: Apr 2011
Location: Delray Beach
Posts: 224
 
You need to have the front Lower Control Arms replaced. When they start to go bad it is intermittent. As the service manager at the Ford dealership I go to explained to me, Ford switched from rubber to hydraulic bushings on the control arms. As they continue to get exposed to heat, they start to go bad. So as they heat up, you will hear squeaking. Eventually, the heat will take it's toll and they will just be shot.

With 2K miles mine are just starting to go bad, they only make noise once I have driven for a while and they get heated up. But soon they will just be shot. They are replacing my LCAs on tuesday.

I see a recall in the near future...

My wheel bearings also went bad at 1K miles! I love my Mustang, but I can't believe all the bad front end parts on these brand new cars!!!

2014 Base GT Black, 6-speed Manual, Tech Package and 3.73 Gears
MODS: GT500 Axlebacks / Cat Delete / Pypes X-Pipe / Strut Tower Brace / OEM leather seats / Black 19" Brembo Wheels / Steeda CAI / BBR 93 Oct Tune / Roush Lowering Springs / BBR Panhard Bar / Whiteline LCAs / Barton Shifter / 8 Ball Shift Knob / JLT Oil Catch Can / Shorty Antenna / RTR Chin Spoiler / CDC Grill / Drilled Rotors / Black Calipers / Hawk HPS PADS
HarrishMasher is offline  
Rookie
 
soulzindadark's Avatar
 
Joined: Jul 2011
Location: dubai, uae
Posts: 1
 
i have the same issue here, squeaking noise from the front end, it this all the mustang 2012's or just the GT.

havent done anything abt it yet but plannin on gettin it looked at.(FORD DEALER IS PRETTY ****** UP HERE)
soulzindadark is offline  
Apprentice
 
HarrishMasher's Avatar
 
Joined: Apr 2011
Location: Delray Beach
Posts: 224
 
Quote:
Originally Posted by soulzindadark View Post
i have the same issue here, squeaking noise from the front end, it this all the mustang 2012's or just the GT.

havent done anything abt it yet but plannin on gettin it looked at.(FORD DEALER IS PRETTY ****** UP HERE)
Seems to affect 2011 and 2012 Mustangs regardless if V6 or GT. I believe the front LCAs are the same on both.

2014 Base GT Black, 6-speed Manual, Tech Package and 3.73 Gears
MODS: GT500 Axlebacks / Cat Delete / Pypes X-Pipe / Strut Tower Brace / OEM leather seats / Black 19" Brembo Wheels / Steeda CAI / BBR 93 Oct Tune / Roush Lowering Springs / BBR Panhard Bar / Whiteline LCAs / Barton Shifter / 8 Ball Shift Knob / JLT Oil Catch Can / Shorty Antenna / RTR Chin Spoiler / CDC Grill / Drilled Rotors / Black Calipers / Hawk HPS PADS
HarrishMasher is offline  
PONY Member
 
ZMoneY's Avatar
 
Joined: Mar 2011
Location: The Rose
Posts: 588
 
TSB says 2011/2012 with build dates before 4/11. Unfortunatly I went in and it wasn't creaking at all cause it was raining but they believed me and order a drivers side LCA which is making a shiit load of noise. I'm sure the passenger will be heard once my drivers side is replaced but it's all good.

2012 GT Black Premium 6MT, 20" Black Foose Nitrous Staggered.

MODS: Airaid CAI, 93 BAMA Performance Tune, Roush Axle-Backs, GT500 Splash Guards, Shorty Antenna, Steeda Black Shift Knob, Extra Chrome Trim, 3rd Brake Light Decal, Aeroforce Interceptor Gauge w/ Roush Vent Pod, Valetine 1.
ZMoneY is offline  
Apprentice
 
HarrishMasher's Avatar
 
Joined: Apr 2011
Location: Delray Beach
Posts: 224
 
Quote:
Originally Posted by ZMoneY View Post
TSB says 2011/2012 with build dates before 4/11. Unfortunatly I went in and it wasn't creaking at all cause it was raining but they believed me and order a drivers side LCA which is making a shiit load of noise. I'm sure the passenger will be heard once my drivers side is replaced but it's all good.
My dealer said they started replacing only one side, as soon as they replaced the one side they heard the other. Now they just replace both sides automatically.

2014 Base GT Black, 6-speed Manual, Tech Package and 3.73 Gears
MODS: GT500 Axlebacks / Cat Delete / Pypes X-Pipe / Strut Tower Brace / OEM leather seats / Black 19" Brembo Wheels / Steeda CAI / BBR 93 Oct Tune / Roush Lowering Springs / BBR Panhard Bar / Whiteline LCAs / Barton Shifter / 8 Ball Shift Knob / JLT Oil Catch Can / Shorty Antenna / RTR Chin Spoiler / CDC Grill / Drilled Rotors / Black Calipers / Hawk HPS PADS
HarrishMasher is offline  
PONY Member
 
ZMoneY's Avatar
 
Joined: Mar 2011
Location: The Rose
Posts: 588
 
Quote:
Originally Posted by HarrishMasher View Post
My dealer said they started replacing only one side, as soon as they replaced the one side they heard the other. Now they just replace both sides automatically.
Yea my dealership already apologized about possibly coming in twice. Quote "ford is very picky when it comes to warranty issues". It wasn't even creaking and they ordered the part which made me happy.

2012 GT Black Premium 6MT, 20" Black Foose Nitrous Staggered.

MODS: Airaid CAI, 93 BAMA Performance Tune, Roush Axle-Backs, GT500 Splash Guards, Shorty Antenna, Steeda Black Shift Knob, Extra Chrome Trim, 3rd Brake Light Decal, Aeroforce Interceptor Gauge w/ Roush Vent Pod, Valetine 1.
ZMoneY is offline  
FordService
Guest
 
FordService's Avatar
 
Posts: n/a
Quote:
Originally Posted by babanist View Post
While cruising i starting hearing some noises but wasnt sure where its coming from...kept driving but paid more attention to that strange new sound im hearing...after few minutes it was clear that the sound was coming from the front end of the car in a form of a "TICK" when i put my foot on the throttle even if gently. I had to go over a speed hump (slowly obviously) and thats when i heard squeaking noise coming from the suspensions...and now there were 2 ticks coming from the front end when i accelerate. I think the ticks were coming from the suspensions too.
Hey babanist,

I agree with the other members about bringing your vehicle in to your Ford dealer for diagnosis. You can also contact the Overseas Military Sales Corporation at 1-516-496-1806 for further assistance if needed.

Deysha

Sponsored Links
Advertisement
 
Reply

Tags
2012 gt premium , squeaking , suspension 5.0 automatic

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1