Issues with recent Steeda CAI kits - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-24-2013 Thread Starter
PONY Member
 
teedub21's Avatar
 
Joined: Jan 2013
Location: Vancouver
Posts: 339
 
Issues with recent Steeda CAI kits

I've been having some surging issues with my Steeda tune and CAI. Gus has been working with me to get the tune right, but the other day requested a photo of the inside of my intake with the filter removed. Apparently over the last 3-4 weeks they've had a rash of cars that wont tune properly. They've narrowed it down to a production run of CAI's where the plastic tube doesn't mate up well with the aluminum velocity stack, causing turbulence in the air stream and bad readings by the MAF. If you've been having issues and recently bought yours, you may want to take a look. They are sending me a new tube and a re-tune. Hopefully this takes care of it!

Here is a photo from Gus at Steeda so you can see what I'm talking about:

Attached Thumbnails
Click image for larger version

Name:	Returned CAI with Bad MAF Signal.jpg
Views:	215
Size:	771.6 KB
ID:	217305  
teedub21 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-24-2013
PONY Member
S197 Member
 
xarius's Avatar
 
Joined: Oct 2012
Location: Fayetteville
Posts: 714
 
Good information! Glad to hear they are taking care of you. I've always received great customer service from everyone at Steeda.


Black 2013 GT Premium | Track Package | Recaros | GT500's | JBA H-Pipe | Borla Over-Axles | OEM GT500 Spoiler | Koni Yellows | Steeda CAI/Tune | Steeda Ultralite Springs | Steeda Adjustable UCA/PHB | Steeda Billet LCAs | MGW | Forgestar F14's
xarius is offline  
post #3 of 5 (permalink) Old 04-24-2013
Grimace427
Guest
 
Grimace427's Avatar
 
Posts: n/a
Very interesting, I'll have a peek at mine.
 
post #4 of 5 (permalink) Old 04-24-2013 Thread Starter
PONY Member
 
teedub21's Avatar
 
Joined: Jan 2013
Location: Vancouver
Posts: 339
 
Just to follow up, Steeda is working closely with those of us affected and I think it is pretty isolated. I wasn't intending to alarm everyone with a Steeda CAI, just make people that have purchased in the last 30 days that may be having problems getting the tune "just right" that this could be the reason.

Gus at Steeda has been awesome in getting this handled for me, and actually brought the issue with the intakes to my attention. I'm relieved that the car actually should run smoother than it has and this is the reason why, not that mine runs terribly.
teedub21 is offline  
post #5 of 5 (permalink) Old 12-29-2013
Rookie
 
slver_06_GT's Avatar
 
Joined: Nov 2007
Location: Sunrise
Posts: 34
 
what is the problem you were having with the tune?

were you getting an error code or was it a performance issue?

thank you.
slver_06_GT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1