'13 power steering noise - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 11-14-2013 Thread Starter
Apprentice
 
Robotaz's Avatar
 
Joined: May 2012
Location: Mexington
Posts: 166
 
'13 power steering noise

I made it to 6,800 miles without a mechanical problem, then yeah, got a problem.

So when I have pressure on the pump, pulling the wheel to the side, I get a rattling noise up front. Let off and it stops.

Shot pump? Thoughts? I really don't know enough about electric steering to know what it would be. If it was a traditional setup, it sounds like a dying pump.

This sucks. I really don't want my car torn apart already.

Robotaz is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 11-14-2013
SHELBY GT 350 Member
 
Ltngdrvr's Avatar
 
Joined: Oct 2010
Location: Southeast
Posts: 7,791
 
There is no pump, it's all electric.

Take it to the dealer and get it checked out.


Ltngdrvr is offline  
post #3 of 10 (permalink) Old 11-15-2013
GT Member
 
Elite_Deforce's Avatar
 
Joined: Dec 2010
Location: Montreal
Posts: 2,492
 
Quote:
Originally Posted by Ltngdrvr View Post
There is no pump, it's all electric.

Take it to the dealer and get it checked out.
In his defence, there is such a thing as electric PS with a pump. Mazda3, for instance.

-2012 Grabber Blue GT 6M Premium w/ Brembos, Glass Roof, HID security pkg, Rear Camera, 401a, FRPP GT500 Axle-backs, Front Pioneer TS-D6802R speakers, JHR bracket, Bondra clutch extension.
-1986 Mazda RX-7 GX - Fast Mirage 16" Wheels, Sumo Firenza 205/60R Tires, slotted brakes + performance pads. Otherwise factory stock.
-2008 Mazda Mazda3 GT Sport - Stock, 5MT.
-2004 Volvo XC90 T5 - Comfort pkg, safety pkg.
-1995 Infiniti G20 - Sold, Pioneer head unit, lighting mods, miss it dearly.
Elite_Deforce is offline  
 
post #4 of 10 (permalink) Old 11-15-2013
SHELBY GT 350 Member
 
Ltngdrvr's Avatar
 
Joined: Oct 2010
Location: Southeast
Posts: 7,791
 
Quote:
Originally Posted by Elite_Deforce View Post
In his defence, there is such a thing as electric PS with a pump. Mazda3, for instance.
I wasn't admonishing the poster, just informing him there was no pump.

Ltngdrvr is offline  
post #5 of 10 (permalink) Old 11-15-2013 Thread Starter
Apprentice
 
Robotaz's Avatar
 
Joined: May 2012
Location: Mexington
Posts: 166
 
I have a Mazda 5 with a pump, so I assumed the setup was similar.

If there's not a pump, what could be rattling or making noise? It doesn't make sense to me. I'm sitting still and there's something in the steering making noise. Could it be electric motor bearings?
Robotaz is offline  
post #6 of 10 (permalink) Old 11-15-2013
SHELBY GT 350 Member
 
Ltngdrvr's Avatar
 
Joined: Oct 2010
Location: Southeast
Posts: 7,791
 
Could be lots of things, but that is what the warranty is for.

Ltngdrvr is offline  
post #7 of 10 (permalink) Old 11-15-2013 Thread Starter
Apprentice
 
Robotaz's Avatar
 
Joined: May 2012
Location: Mexington
Posts: 166
 
OK, man. It's scheduled for service, and was. I get it.

I still want to know if anyone has any idea what is wrong. Hopefully it's OK if I ask questions on a car forum.
Robotaz is offline  
post #8 of 10 (permalink) Old 11-15-2013
GT Member
 
Elite_Deforce's Avatar
 
Joined: Dec 2010
Location: Montreal
Posts: 2,492
 
Quote:
Originally Posted by Ltngdrvr View Post
I wasn't admonishing the poster, just informing him there was no pump.
I know, I was just trying to make him feel better if he was embarrassed for some reason.

-2012 Grabber Blue GT 6M Premium w/ Brembos, Glass Roof, HID security pkg, Rear Camera, 401a, FRPP GT500 Axle-backs, Front Pioneer TS-D6802R speakers, JHR bracket, Bondra clutch extension.
-1986 Mazda RX-7 GX - Fast Mirage 16" Wheels, Sumo Firenza 205/60R Tires, slotted brakes + performance pads. Otherwise factory stock.
-2008 Mazda Mazda3 GT Sport - Stock, 5MT.
-2004 Volvo XC90 T5 - Comfort pkg, safety pkg.
-1995 Infiniti G20 - Sold, Pioneer head unit, lighting mods, miss it dearly.
Elite_Deforce is offline  
post #9 of 10 (permalink) Old 11-21-2013
FordService
Guest
 
FordService's Avatar
 
Posts: n/a
Quote:
Originally Posted by Robotaz View Post
I made it to 6,800 miles without a mechanical problem, then yeah, got a problem.

So when I have pressure on the pump, pulling the wheel to the side, I get a rattling noise up front. Let off and it stops.

Shot pump? Thoughts? I really don't know enough about electric steering to know what it would be. If it was a traditional setup, it sounds like a dying pump.
Hi Robotaz,

Glad to learn youre already bringing it in to get looked at. Id also like to get this escalated to the customer service manager for your area. Please PM me with your VIN, dealer, mileage, full name, and best daytime number.

Deysha
post #10 of 10 (permalink) Old 06-09-2014 Thread Starter
Apprentice
 
Robotaz's Avatar
 
Joined: May 2012
Location: Mexington
Posts: 166
 
I just now got a chance to take it in. I have a list of issues, so I'm concerned that one or more gets brushed under the rug by the dealer.

I'm hoping that the suspension noise, power steering rack, computer recall, and first-gear lunge when coming to a stop all get fixed.
Robotaz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1