Trunk latch failing - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 05-27-2015 Thread Starter
Apprentice
5.0L Member
 
mmcgan11's Avatar
 
Joined: May 2011
Location: West Chester
Posts: 243
 
Trunk latch failing

Hey all the trunk latch is failing on my 2012. Makes the standard horrible buzzing sound, won't close sometimes, shows Trunk Ajar status at times...

Took it to the dealer (cough Garnet Ford, Chadds Ford, PA, cough) last year before the warranty was up (just as I did with the rear stabilizer end links) and was told "nothing is wrong."

Anyhow, now I'm out of warranty (shocking) and after paying to fix the stabilizer links, I'm trying to figure out whether the latch system is something I can take on and whether the parts are something I can order. I know there was a TSB on the parts and a redesign....


2012 Candy red GT convertible premium, MT82, comfort package. Black int/black roof.
mmcgan11 is online now  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-27-2015
SHELBY GT 350 Member
4.6L Member
S197 Member
 
JBert's Avatar
 
Joined: Jan 2011
Location: Central Massachusetts
Posts: 8,891
           
Don't suppose you got some kind of receipt or record of taking it to them while it was still under warranty?

I had that problem on my 2010, and I did get it fixed under warranty. And yeah I'm pretty sure there is a TSB. Can't tell you how hard it is to do, because the dealer did it.


| 2010 GT coupe | Daily Driver with some Steeda and GT500 take-off stuff for the occasional track day
JBert is online now  
post #3 of 5 (permalink) Old 05-27-2015
PONY Member
 
JimC's Avatar
 
Joined: Feb 2007
Location: Fort Gratiot
Posts: 777
 
I had that problem on my wife's 2006 Focus - you have to adjust the latch, something has knocked it out of alignment.

2013 MCA Convertible, automatic - Revelare Designs cowl hood, Hellion single turbo.
JimC is offline  
 
post #4 of 5 (permalink) Old 05-28-2015
Apprentice
 
Toddo1's Avatar
 
Joined: Mar 2011
Location: D Town
Posts: 146
 
If the latch solenoid is buzzing when you open the trunk, Ill bet the deck lid is sticking to the weatherstrip. Rub some silicone product on the weatherstrip. This happens to mine about once a year.
Toddo1 is offline  
post #5 of 5 (permalink) Old 05-28-2015
SHELBY GT 350 Member
4.6L Member
S197 Member
 
JBert's Avatar
 
Joined: Jan 2011
Location: Central Massachusetts
Posts: 8,891
           
Quote:
Originally Posted by Toddo1 View Post
If the latch solenoid is buzzing when you open the trunk, Ill bet the deck lid is sticking to the weatherstrip. Rub some silicone product on the weatherstrip. This happens to mine about once a year.
This is worth a try, and it is what the dealer told me to do, before they actually looked up the TSB and fixed it. For me, it did not help.

| 2010 GT coupe | Daily Driver with some Steeda and GT500 take-off stuff for the occasional track day
JBert is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1