Front end brakes or suspension (noise) - Ford Mustang Forum
Like Tree1Likes
  • 1 Post By David Young
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 05-19-2019 Thread Starter
Rookie
 
ThreePoint7's Avatar
 
Joined: May 2019
Posts: 1
 
Hey everyone,

2014 Mustang V6-Performace Package(stock)
I’m brand new here and am hoping someone can shed some light on this. I’m sure there might be another post like this but this is a little different.

I have been experiencing a pop then grind kind of noise when turning, specifically right, but what’s different is it does it more often and much louder when I brake. Now this occurs usually when pulling into a parking spot because most of the time you have to brake.

If I turn into a parking spot at the same speed but don’t brake I hardly get a noise at all (coasting). I just had sway bar end links out on at a Ford dealership and at that time they said everything seemed okay. I wanted to see if anyone else knew what this new noise could be? The vehicle is now out of warranty as of April (go figure). Thanks!

Update: It had rained an hour ago and I attempted this again but could not replicated. Odd.

Alex


Last edited by ThreePoint7; 05-19-2019 at 06:18 PM.
ThreePoint7 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-20-2019
PONY Member
 
GT'sGT's Avatar
 
Joined: Apr 2018
Posts: 933
 
Check the ball joints. Also look to see that all the bolts are in the calipers and are tight.

GT'sGT is offline  
post #3 of 5 (permalink) Old 05-20-2019
PONY Member
 
David Young's Avatar
 
Joined: Oct 2012
Location: Clinton
Posts: 934
 
Could be your strut mounts also.
bl817 likes this.

'Little Red'. 2011 V-6 Mustang. Automatic Trans. C&L C.A.I. Ceramic Coated BBK Long Tube Headers and Catted Shorty X-Pipe. Magnaflow Street Series Axle Backs. 3.73 rear gears. GT 500 Lower Control Arms. JLT Catch Can. Axle Exchange Aluminum Drive Shaft. Steeda Watts Link. Several more mods...1991 F150 4X4 59,000 miles. Wifes car, 2014 Ford Edge Limited.
David Young is offline  
 
post #4 of 5 (permalink) Old 05-20-2019
Apprentice
 
xavicho3's Avatar
 
Joined: Feb 2016
Posts: 140
 
Go on a level ground and unbolt/re-bolt the strut mount bolts
My clunking went away with a strut tower install. I do have a bad endlink tho
But no more clunk, go figure
xavicho3 is offline  
post #5 of 5 (permalink) Old 07-20-2019
Rookie
 
jayochs's Avatar
 
Joined: Feb 2017
Posts: 15
 
jayochs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
after suspension work, now have clunking noise in the rear end dannyk77 2005-2010 Mustang GT Tech 5 05-07-2016 02:15 PM
2001 Cobra front end issues, need some insight. bevil77 SVT Cobra Tech 6 03-17-2010 12:36 AM
1965 Mustang Front Suspension ZMustang Classic Tech 4 03-08-2010 07:48 PM
1987 ford mustang lcyoung5 5.0L Talk 4 10-28-2009 12:34 PM
2005 Mustang GT Front End Noise frdfrst 2005-2010 Mustang GT Tech 4 08-06-2009 09:18 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1