2012 V6 Premium noise in front end. - Page 2 - Ford Mustang Forum
Reply
 
LinkBack Thread Tools
PONY Member
 
KonaV6's Avatar
 
Joined: Mar 2013
Location: NWF
Posts: 306
 
*UPDATE*

I took my car in for the same issue. It ended up being the Left LCA, they said they're going to replace both. The Left LCA came in, it took them two days to tell me the Right LCA is on backorder with a To Be Announced date. They did give me a rental this entire time, it seems like a waste to give me a rental when you don't even know if the hardware will be in or not. I'll be dropping my rental off on Saturday to get my car back (unless it comes in tomorrow, most likely not), then bring it back again when the parts come in. It's about an hour away from my house also.

Make sure they have the parts in before taking your car in. I lived and learned.

KonaV6 is offline  
Sponsored Links
Advertisement
 
post #17 of 66 (permalink) Old 08-13-2013 Thread Starter
Rookie
4.6L Member
S197 Member
 
trivas1's Avatar
 
Joined: May 2008
Location: Stockbridge
Posts: 11
 
noisy front end

Quote:
Originally Posted by FordCustSrvc View Post
Hello trivas1,

You should have it checked out at your dealer and speaking to your Service Manager about this. He/She is in the best position to look into this for you. He/she can check into any warranty, assistance, recalls, or Customer Satisfaction Programs that may apply to your vehicle. Let me know the outcome.

Deysha
Well here is my update:
Still not fixed. Took to dealer the loaned me a car for about 4 days then called me to say that lower control arms are on back order. Took loaner car back in and got our car so we then took a trip out of town. As we were leaving they called us to tell me that the parts were in, so we scheduled the repair the following week after we got back. Took car in and later that afternoon the service adviser said the parts were incorrect and come get the car because he does not know when the improved parts would be in. So I am somewhat disappointed but these kind of things happen as I have been in those shoes before as well.
I believe they have a remedy for the issue but not enough supply for the demand at this time.

trivas1 is offline  
Apprentice
 
obokky's Avatar
 
Joined: Jan 2013
Location: DFW
Posts: 136
 
Is this the sound that is reminiscent of an old steamer trunk squeaking across a floor on those miserable little wheels (pre-casters)?

Mine just started that under moderate braking a few days ago.

I have a standing game of phone tag with a local service advisor to get other warranty work done. It started as a decal replacement (both sides' MCA rockers) and has grown to include a nasty rattle at headliner/windshield before this.

He was denying a loaner for the decal work, but it may have steamrolled on him beyond that point.


2013 Mustang 227 | MT82 | MCA | Performance Pack

Previously...
First Car: 1979 Mustang 2.3L Turbo MT, Indianapolis Pace Car
First New Car: 1997 Mustang GT 4.6L MT
obokky is offline  
 
FordService
Guest
 
FordService's Avatar
 
Posts: n/a
Quote:
Originally Posted by trivas1 View Post
Well here is my update:
Still not fixed. Took to dealer the loaned me a car for about 4 days then called me to say that lower control arms are on back order. Took loaner car back in and got our car so we then took a trip out of town. As we were leaving they called us to tell me that the parts were in, so we scheduled the repair the following week after we got back. Took car in and later that afternoon the service adviser said the parts were incorrect and come get the car because he does not know when the improved parts would be in. So I am somewhat disappointed but these kind of things happen as I have been in those shoes before as well.
I believe they have a remedy for the issue but not enough supply for the demand at this time.
Quote:
Originally Posted by obokky View Post
Is this the sound that is reminiscent of an old steamer trunk squeaking across a floor on those miserable little wheels (pre-casters)?

Mine just started that under moderate braking a few days ago.

I have a standing game of phone tag with a local service advisor to get other warranty work done. It started as a decal replacement (both sides' MCA rockers) and has grown to include a nasty rattle at headliner/windshield before this.

He was denying a loaner for the decal work, but it may have steamrolled on him beyond that point.
Thank you for the update, trivas1!

Both of you should PM me with your VIN, dealer, full name, mileage, and best daytime number so I can escalate this for you.

Deysha
post #20 of 66 (permalink) Old 08-23-2013 Thread Starter
Rookie
4.6L Member
S197 Member
 
trivas1's Avatar
 
Joined: May 2008
Location: Stockbridge
Posts: 11
 
I just PM'ed you with my information. I am not at all mad, however it does disappoint just a bit. Not what I expected from Ford. Then again I do work with construction equipment and know well how this can go.

Thanks Deysha!
trivas1 is offline  
Sean Reilly
Guest
 
Sean Reilly's Avatar
 
Posts: n/a
There is a "Sticky" about this issue including the Newest TSB up at the top of this page
The newest front LCA Revision includes the newest LCA's with the added Heat shields!
Apprentice
 
moto2000's Avatar
 
Joined: Aug 2012
Location: San Diego
Posts: 139
 
Garage
Quote:
Originally Posted by KonaV6 View Post
I had the same issue when going over speed bumps. I took it in yesterday and they confirmed the lower control arm was bad on the left side. They're replacing both the fronts with the "improved" LCAs under warranty. This issue is pretty common from what I've read on this forum. I'll post up how everything looks and sounds after the install them later this week.

My noise was coming from the front end, no rear end clunks. You can always do the CPR test on your struts, and if they make a bunch of noise when you press down on each front strut then those may be the issue. Could also be a bad LCA bushing or a Swaybar end link, take it in and let them figure it out under warranty
What year is your stang?

2013 Sterling Gray Metallic 3.7L V6 Premium, Pony/Comfort/Security Package, Airaid CAI, Bama V2 91P tune, GT 80mm Throttle Body, Dynomax Catbacks, Boss 302 Strut Tower Brace, Eibach rear & GT front Sway Bars, SR Performance LCA's, BMR Panhard Bar, Koni Str.t shocks, Michelin Pilot SS
moto2000 is offline  
FordService
Guest
 
FordService's Avatar
 
Posts: n/a
Quote:
Originally Posted by trivas1 View Post
I just PM'ed you with my information. I am not at all mad, however it does disappoint just a bit. Not what I expected from Ford. Then again I do work with construction equipment and know well how this can go.

Thanks Deysha!
Thanks, trivas1! I sent you a PM.

Deysha
post #24 of 66 (permalink) Old 09-05-2013 Thread Starter
Rookie
4.6L Member
S197 Member
 
trivas1's Avatar
 
Joined: May 2008
Location: Stockbridge
Posts: 11
 
Well I am happy to say my Mustang is fixed. It was only in the shop for a day. Thanks to Ford Customer Service for the help! Thank you Deysha!
trivas1 is offline  
Apprentice
 
obokky's Avatar
 
Joined: Jan 2013
Location: DFW
Posts: 136
 
Quote:
Originally Posted by trivas1 View Post
Well I am happy to say my Mustang is fixed. It was only in the shop for a day. Thanks to Ford Customer Service for the help! Thank you Deysha!
That's great news!

Mine was in yesterday for the official diagnosis which turned out to be: LCA's!?!
Lol.

So they're on order and we'll see what the ETA looks like.


2013 Mustang 227 | MT82 | MCA | Performance Pack

Previously...
First Car: 1979 Mustang 2.3L Turbo MT, Indianapolis Pace Car
First New Car: 1997 Mustang GT 4.6L MT
obokky is offline  
FordService
Guest
 
FordService's Avatar
 
Posts: n/a
Quote:
Originally Posted by trivas1 View Post
Well I am happy to say my Mustang is fixed. It was only in the shop for a day. Thanks to Ford Customer Service for the help! Thank you Deysha!
Awesome! You’re very welcome, trivas1!

Quote:
Originally Posted by obokky View Post
That's great news!

Mine was in yesterday for the official diagnosis which turned out to be: LCA's!?!
Lol.
So they're on order and we'll see what the ETA looks like.
Thanks for the update, obokky!

Deysha
Rookie
 
cdonofrio's Avatar
 
Joined: Sep 2013
Location: Clarksville
Posts: 2
 
2013 V6 Front Suspension Noise

I have a 2013 V6 with ~9800 miles and recently noticed a front end noise when going over speed bumps slowly. I hear it from the driver side only. It's hard to describe the sound but I was able to capture a fairly decent sound clip...

2013 V6 Mustang Front End Noise - YouTube

I plan to take it to the dealer this week but was wondering if anyone has had a similar issue?!
cdonofrio is offline  
SHELBY GT 350 Member
 
Ltngdrvr's Avatar
 
Joined: Oct 2010
Location: Southeast
Posts: 7,791
 
LOTS of people have had a similar issue, do a search and you will find tons of threads about it.

Ltngdrvr is offline  
Apprentice
 
metaman's Avatar
 
Joined: Sep 2010
Location: Southeast
Posts: 209
 
It is the stock upper strut mount. Compared to the optional upgrade of the 2011 GT500 strut mount they are flimsy. Mine made noise at 4500 miles. Luckily I was replacing them with the FRPP springs anyway. The side that was making noise on mine just came apart upon taking the strut apart. Kind of an out of focus picture, but you can see the problem.


2013 Grabber Blue Premium Couple, Auto, FRPP N Springs, FRPP Dampeners, Lund Tune
metaman is offline  
Rookie
 
mmanqso's Avatar
 
Joined: Jan 2013
Location: Lexington
Posts: 21
 
Just took my 2013 v6 in for front suspension noise (among other issues) . The noise was from the right front. The dealer replaced both front lower control arms per a TSB. They said the right one needed to be replaced and the left was borderline, so they replaced both.

mmanqso is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1