Weird engine clicking sound - Page 2 - Ford Mustang Forum
Reply
 
LinkBack Thread Tools
post #16 of 20 (permalink) Old 09-22-2013 Thread Starter
Apprentice
 
krnxboyxjoe's Avatar
 
Joined: Sep 2012
Location: Arlington
Posts: 233
 
Well went to the dealership talked with the guy and he said if they can't replicate the sound he can't fix it. Go figure. So I have to get the sound to replicate at the dealership, videos won't cut it :/


2011 V6 Black Mustang Automatic: Magnaflow Competition Series Cat-Back Exhaust, Airaid Cold Air Intake, Raxiom Smoked Projector Headlights, Raxiom Smoked Aero Tail Lights, 93H-R3.1 Bama tune, BBK Long Tube Headers, BBK Catted X Pipe
krnxboyxjoe is offline  
Sponsored Links
Advertisement
 
FordService
Guest
 
FordService's Avatar
 
Posts: n/a
Quote:
Originally Posted by krnxboyxjoe View Post
Well went to the dealership talked with the guy and he said if they can't replicate the sound he can't fix it. Go figure. So I have to get the sound to replicate at the dealership, videos won't cut it :/
Were you able to ride with the tech, krnxboyxjoe? This way you can show him what you hear. Also, PM me with your VIN, dealer, mileage, full name, and best daytime number so I can escalate this to the customer service manager for your area.

Deysha

post #18 of 20 (permalink) Old 09-27-2013 Thread Starter
Apprentice
 
krnxboyxjoe's Avatar
 
Joined: Sep 2012
Location: Arlington
Posts: 233
 
I was not able to, however I don't typically hear the sound while driving. It happens more when I'm pulling in to a place to park.

2011 V6 Black Mustang Automatic: Magnaflow Competition Series Cat-Back Exhaust, Airaid Cold Air Intake, Raxiom Smoked Projector Headlights, Raxiom Smoked Aero Tail Lights, 93H-R3.1 Bama tune, BBK Long Tube Headers, BBK Catted X Pipe
krnxboyxjoe is offline  
 
Rookie
 
Mustangguy17's Avatar
 
Joined: Jun 2013
Location: Pace
Posts: 43
 
If it happened after your oil change.... Are you sure you screwed on the filter and put in the proper amount of oil/removed all old oil?

2014 5.0 MT Sterling grey
Mustangguy17 is offline  
post #20 of 20 (permalink) Old 09-27-2013 Thread Starter
Apprentice
 
krnxboyxjoe's Avatar
 
Joined: Sep 2012
Location: Arlington
Posts: 233
 
Quote:
Originally Posted by Mustangguy17 View Post
If it happened after your oil change.... Are you sure you screwed on the filter and put in the proper amount of oil/removed all old oil?

Well it was professionally done, so it would not be my error if there was a problem. These guys have changed my oil ever since I got the car with out a single problem so I don't think it would be that, however who knows, anyone can make a mistake. He put all 6 qts in and screwed on the filter using the tool to tighten it so I think those bases are covered, as I did watch him perform the change.

2011 V6 Black Mustang Automatic: Magnaflow Competition Series Cat-Back Exhaust, Airaid Cold Air Intake, Raxiom Smoked Projector Headlights, Raxiom Smoked Aero Tail Lights, 93H-R3.1 Bama tune, BBK Long Tube Headers, BBK Catted X Pipe
krnxboyxjoe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1