K&N Drop In filter throws air flow codes.. 2014 V6 - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 15 (permalink) Old 04-05-2014 Thread Starter
Apprentice
 
Commishbob's Avatar
 
Joined: Mar 2014
Location: Houston
Posts: 146
 
K&N Drop In filter throws air flow codes.. 2014 V6

I dropped a K&N filter into my three week old V6 (1k miles) Wednesday night and drove to work Thursday morning. When I cranked the car to leave the lot I was hit with a dashboard full of idiot lights as well as a message area telling me to 'Service Advancetrack'.

I took the car to the closest Ford dealer and they advised me that Ford 'discourages the use of K&N filters'. They cleared the codes, I dropped the oem filter back in and merrily went on my way.

Interestingly the box the K&N came in says 'developed with Ford Racing' right next to a nice big blue oval.

I checked with K&N today and the rep is sending me a refund for the filter and cleaning kit I had purchased. He also told me something I had considered, that the computer would eventually 're-learn' the air flow if I decided to keep the K&N in the car. But driving around for x number of miles with the dashboard lit up like Times Square didn't thrill me.

I've read numerous posts re: K&N drop in filters in late model Mustangs. Many of them have debated the advantages of the K&N drop ins or lack thereof. My feeling was that I might get a bit better mileage and the cost of replacing paper filters makes the K&N a smart 'investment'. I have not seen anyone report the symptoms I experienced. Any thoughts?

Just for fun here is a shot of my dashboard when I pulled into the dealers driveway.

Attached Thumbnails
Click image for larger version

Name:	photo.JPG
Views:	164
Size:	563.2 KB
ID:	332201  

https://lh4.googleusercontent.com/5y4sYLaa80wAyQjKEIg3pD2yCLA4tme9KngRDV5O5EU=w427-h207-p-no

\\2014 V6 coupe, all black\\. Tech, FP6 Appearance and Sensing/Security packages. Tinted and blacked out except headlights. Headlight splitters, MMD Hood Struts, etc
Commishbob is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 04-05-2014
PONY Member
 
David Young's Avatar
 
Joined: Oct 2012
Location: Clinton
Posts: 946
 
I've read about losing 1 or 2 horsepower with the K&N drop in filter but never have seen or read anything like what has happened to you


'Little Red'. 2011 V-6 Mustang. Automatic <acronym title="transmission">Trans</acronym>. C&L C.A.I. Ceramic Coated BBK Long Tube Headers and Catted Shorty X-Pipe. Magnaflow Street Series Axle Backs. 3.73 rear gears. GT 500 Lower Control Arms. JLT Catch Can. Axle Exchange Aluminum Drive Shaft. Steeda Watts Link. Several more mods...1991 F150 4X4 61,000 miles. Wifes car, 2014 Ford Edge Limited.
David Young is offline  
post #3 of 15 (permalink) Old 04-05-2014
SHELBY GT 500 Member
5.0L Member
 
Smurf stang's Avatar
 
Joined: Apr 2009
Location: Miami
Posts: 13,138
 
Never heard of that.

2016 VW GTI 4 door DSG
1989 Sonic Blue Mustang LX Coupe, 349 ci,
392 rwhp 424 rwtq....Mustang Dyno
"There are three kinds of men. The one that learns by reading. The few who learn by observation. The rest of them have to pee on the electric fence for themselves." -Will Rogers-
Smurf stang is offline  
 
post #4 of 15 (permalink) Old 04-05-2014
PONY Member
 
kirbster's Avatar
 
Joined: Sep 2012
Location: Rockwall
Posts: 295
 
I've never heard of that either and have had K&N filters in other cars without any issues.
kirbster is offline  
post #5 of 15 (permalink) Old 04-05-2014
Apprentice
 
golkhl's Avatar
 
Joined: Jun 2010
Location: Las Vegas
Posts: 78
 
Always had good results with k&n filters, been running them in my cars for the past 19 years. Funny how the dealer said that Ford discourages the use of filters that Ford Racing sells.
golkhl is offline  
post #6 of 15 (permalink) Old 04-05-2014
Apprentice
 
3pt7v6xer's Avatar
 
Joined: Apr 2013
Location: Vero Beach
Posts: 173
 
Only issue I have ever had was on a '97 T-Bird - the filament in the MAF got too much oil on it and it made the CPU unhappy with the readings. I cleaned it with Windex and a Q-Tip....drove for another 175k miles until a drunk in a Cavalier decided to park in the back seat......nice car - gone.
3pt7v6xer is offline  
post #7 of 15 (permalink) Old 04-05-2014 Thread Starter
Apprentice
 
Commishbob's Avatar
 
Joined: Mar 2014
Location: Houston
Posts: 146
 
I wondered if I had left the K&N in the car but unplugged the battery for a bit if the computer would 'relearn' the ratio and be accepting of the K&N?

https://lh4.googleusercontent.com/5y4sYLaa80wAyQjKEIg3pD2yCLA4tme9KngRDV5O5EU=w427-h207-p-no

\\2014 V6 coupe, all black\\. Tech, FP6 Appearance and Sensing/Security packages. Tinted and blacked out except headlights. Headlight splitters, MMD Hood Struts, etc
Commishbob is offline  
post #8 of 15 (permalink) Old 04-05-2014 Thread Starter
Apprentice
 
Commishbob's Avatar
 
Joined: Mar 2014
Location: Houston
Posts: 146
 
And to top it off, the filter the service tech and service writer told me was NOT recommended by Ford is for sale right here on the Ford Racing site. WTH?

2010-2014 MUSTANG GT & 2011-2014 V6 HIGH-FLOW K&N / FORD RACING AIR FILTER | Part Details for M-9601-MGT | Ford Racing Performance Parts

https://lh4.googleusercontent.com/5y4sYLaa80wAyQjKEIg3pD2yCLA4tme9KngRDV5O5EU=w427-h207-p-no

\\2014 V6 coupe, all black\\. Tech, FP6 Appearance and Sensing/Security packages. Tinted and blacked out except headlights. Headlight splitters, MMD Hood Struts, etc
Commishbob is offline  
post #9 of 15 (permalink) Old 04-06-2014
Rookie
 
OkieGT's Avatar
 
Joined: Mar 2014
Location: Tulsa
Posts: 47
 
Quote:
Originally Posted by Commishbob View Post
And to top it off, the filter the service tech and service writer told me was NOT recommended by Ford is for sale right here on the Ford Racing site. WTH?

2010-2014 MUSTANG GT & 2011-2014 V6 HIGH-FLOW K&N / FORD RACING AIR FILTER | Part Details for M-9601-MGT | Ford Racing Performance Parts
As you continue to deal with dealership service writers and techs, you will realize they are programmed to peddle the OEM parts almost to the level of stupidity. The fact they claim the K&N filter isn't recommended in a Ford application while Ford Racing sells the filter and even claims to have helped develop it, proves my point. I would find a new dealer.
OkieGT is offline  
PONY Member
 
Plumbago's Avatar
 
Joined: Jun 2010
Location: Iowa
Posts: 562
 
I doubt the K&N filter had anything to do with an Advancetrack problemmmmmmm......best regards Plum
Plumbago is offline  
PONY Member
 
David Young's Avatar
 
Joined: Oct 2012
Location: Clinton
Posts: 946
 
Quote:
Originally Posted by Plumbago View Post
I doubt the K&N filter had anything to do with an Advancetrack problemmmmmmm......best regards Plum
I agree. I must add: I used a K&N drop in filter for several months while C&L was making their first c.a.i. for our 2011 V6 Mustangs back in 2010 without any problems

'Little Red'. 2011 V-6 Mustang. Automatic <acronym title="transmission">Trans</acronym>. C&L C.A.I. Ceramic Coated BBK Long Tube Headers and Catted Shorty X-Pipe. Magnaflow Street Series Axle Backs. 3.73 rear gears. GT 500 Lower Control Arms. JLT Catch Can. Axle Exchange Aluminum Drive Shaft. Steeda Watts Link. Several more mods...1991 F150 4X4 61,000 miles. Wifes car, 2014 Ford Edge Limited.
David Young is offline  
GT Member
V6 Member
S197 Member
 
audioAl's Avatar
 
Joined: Mar 2012
Location: Port Lavaca,Tx.
Posts: 1,037
 
Garage
It was the 1st thing I did after I got my 3.7, it had 9,000 on the clock. I still use K&N drop-in. I clean it a lot as it gets bugs in it.

2012 Candy Red 3.7 Cyclone {RIP}
2014 3.7 Cyclone DIB\BMR rear lca;s\ American Racing razor 18x9\275/40/18 Yokohama S-drives\Boss 302 strut brace\Airaid "tube"& aFe inverted Dry-S drop-in\UPR catch can\Koni sports\J&M cc plates\DSS 3.5" 1 piece
Bassani\BMR adj. panhard\
audioAl is offline  
Rookie
 
DaveWms's Avatar
 
Joined: Sep 2013
Location: Farmers Branch
Posts: 19
 
There's also a note under 'Tech Notes' that says "Does not require PCM recalibration".

I wonder if something might have been loose as a result of installing the filter?

2014 Mustang V6 Premium w/Pony and Comfort Packages. White w/Light Stone interior.

(The Coyote was tempting, but I already have a hot rod!)

1968 Chevelle, 383ci SBC, tri-power, 4-speed, longtubes, Magnaflows.
DaveWms is offline  
PONY Member
 
gshabanov's Avatar
 
Joined: Jun 2011
Location: CA
Posts: 280
 
Quote:
Originally Posted by DaveWms View Post
There's also a note under 'Tech Notes' that says "Does not require PCM recalibration".

I wonder if something might have been loose as a result of installing the filter?
I agree with DaveWms. Something must have been loose or not properly closed.

2012 v6 Tri Yellow Performance Package.
Upgrade to interior only so far.
gshabanov is offline  
PONY Member
 
KonaV6's Avatar
 
Joined: Mar 2013
Location: NWF
Posts: 306
 
Quote:
Originally Posted by gshabanov View Post
I agree with DaveWms. Something must have been loose or not properly closed.
3rd that. I just put my stock airbox in with the K&N panel filter from my AirRaid CAI and i've been driving with no issues for about a month or so.

KonaV6 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1