Ford Mustang Forum - View Single Post - This is the stereo system I have put together, what do you think?
View Single Post
post #23 of (permalink) Old 01-08-2012
GoT midlife CS
GT Member
5.0L Member
S197 Member
 
GoT midlife CS's Avatar
 
Joined: Aug 2011
Location: District 6
Posts: 1,370
 
Quote:
Originally Posted by fake View Post
Ok, so if I go with the JL XD600, then I will need the JL Clean Sweep? Sorry for the ignorance. Obviously things have changed from when I was into this stuff 19 years ago.
Fake,

I originally used the cleansweep with my system and although it sounded great at first. it failed after a month or so. I now use the AudioControl LC2i (2 of them) one for the bass and one for the front. If you plan to amplify all four channels plus a sub ( i only amplify the front channels and a sub) then look into the LC6i. This Loc will take signals from your front subs, front 5X7's and rear 5X7's and sum them all together. If i were to do it again this is how I would do it.

Cheers.

2012 GT CS Ingot Silver Vert, Edelbrock E-force supercharger with CAI and 3.5 Pulley, Tremec T-56 Mag, Accufab 84.5, Centerforce DF, Billet Yoke aluminum driveshaft, FRPP 3.73 Rear, MRT Performance H-pipe, Bassani axle backs, JL Audio sound, Edelbrock strut tower brace, JPC adjustable UCA, UMI adjustable panhard bar, KW V3 coilovers, Steeda heavy duty front mounts, Steeda rear LCA's, 20" Steeda Spyders with Michelin Pilot Super Sports, Steeda Big Brake Kit ....... it just keeps going.
GoT midlife CS is offline  
 
 
For the best viewing experience please update your browser to Google Chrome