Ford Mustang Forum - View Single Post - AdvancTrac almost caused a major wreck
View Single Post
post #1 of (permalink) Old 07-26-2012
11Red3.7
Guest
 
11Red3.7's Avatar
 
Posts: n/a
AdvancTrac almost caused a major wreck

It was 80F, on a clear, flat, smooth dry on ramp. I tried to get around an 18 wheeler hauling rocks. I had TC off, and went to 2/3 or 3/4 throttle, didn't even floor it, when I got along side the truck the TC Active light came on cutting the throttle and slaming on each brake individually in a clockwise order. I wasn't even coming close to breaking any traction, and this went on for a while. I pulled over, put it in park then pulled back out to get on the freeway. I very slowly and steadilly pulled up to about 50mph and the TC freaked out again!! Slamming each individual brake so hard I began swirving badly, and I'm in the middle lane with traffic passing me on both sides now. Even when I slowed way down it is still going nuts. The TC button would not work, I couldn't turn TC or advanctrac on, off or anything. Finally I made it to the shoulder, turned the car off for several minutes and babyed the car home.
I have an appointment with the dealer tomorrow. I've been postponing the shifting TSB, and the squeaky belt TSB hoping they would happen more often making it easier to diagnose. Also my steering wheel buttons are looking bad, flaking off paint. Sure hope they can get me fixed up. Just don't want to hear that they drove around the block and it drove fine for them...

Anyone have a similar TC event?

 
 
 
For the best viewing experience please update your browser to Google Chrome