Ford Mustang Forum - View Single Post - AdvancTrac almost caused a major wreck
View Single Post
post #54 of (permalink) Old 07-31-2012
Grimace427
Guest
 
Grimace427's Avatar
 
Posts: n/a
Quote:
Originally Posted by 11Red3.7 View Post
I don't own a Performance Package , but I almost always just tap the TC button once but leave AdvancTrac on. I think it was last year a member on here lost control on the 1/4 mile which ended up killing her competetor in the other lane. Her husband wrote up the details on here, since then I mostly leave AdvancTrac engaged.

The first time it "engaged" I was accelerating somewhat aggressively, but come on! I'm pretty much stock with 2.73s!!!!
The second time a couple minutes later I was very, very slowly accelerating cause I was nervous as hell, and the brakes behaved like the car thought I was in an uncontrolable spin, but I had been driving smooth, straight, and flat. When each individual brake slammed then I was swirving almost out of control. If I had been doing 70mph things could have gone south really fast, like the Ford Exploders of old. The more I think about it the scarier it gets, it is supposed to be a safety system that intervenes when things go wrong. But if a tiny glitch in the system causes this kind of thing, I'd rather not have the safety Nanny at all.
My service advisor just now called and they can not duplicate it at all, have no codes, and Ford he says has no advice on how to proceed. Nervous as hell to drive this car home, or anywhere else...
For something that much of a safety issue, I would insist on them testing each wheelspeed sensor via oscilloscope pattern as well as swap in a new AdvanceTrac control unit for diagnostic purposes. Get Deysha to light a fire beneath their butts. I understand the difficult to duplicate and diagnose concerns being a tech myself, but for things safety related we check until we are certain it is fixed.
 
 
 
For the best viewing experience please update your browser to Google Chrome