Ford Mustang Forum - View Single Post - tires break loose after launch
View Single Post
post #4 of (permalink) Old 09-26-2012
Sharad
SHELBY GT 350 Member
 
Sharad's Avatar
 
Joined: Nov 2010
Location: Fort Myers
Posts: 6,462
       
Quote:
Originally Posted by vpap1 View Post
so ... been to the track and finaly ran a slow 13.0 at 107 with a high 1.98 after getting the car back after 3 runs, car makes 350 rwhp, but finally hooks good

when the car launches, and the front end comes down hard the rear tires break loose and i need to modulate the throttle to get her back in line

i have stock springs and shocks and the sway bar is removed

how can i battle the tire spin for now, untill i find the cash for drag springs and adjustable shocks???

should i reinstall the sway bar??
thanks

V
Quote:
Originally Posted by stang93mustang View Post
You can't really do anything but play with tire pressure. Suspension is the key to any racing (ask me how I know!) Haha

Even if you went old school and got some 90/10 shocks on front and 50/50 on rear, you will notice a difference

Get a hold of Sharad on here for discounted UPR parts.
Thanks Reese.

vpap- like I told you in your other thread, you need to slip the clutch instead of side stepping it. Drag radials don't like to be shocked on the launch.

Let me know when you're ready to upgrade the suspension and I'll hook you up.


Like us at Facebook.com/TeamUPR
Follow us on Instagram @uprproducts
Ask me about the discount on UPR Products for AFM members!
Sharad is offline  
 
 
For the best viewing experience please update your browser to Google Chrome