Ford Mustang Forum - View Single Post - DD 8 inch sub + Sony xlode 800w amp
View Single Post
post #4 of (permalink) Old 09-30-2012
mtu245
PONY Member
V6 Member
S197 Member
 
mtu245's Avatar
 
Joined: Oct 2011
Location: Vancouver
Posts: 556
 
Hmm should be fine. How do you have it setup? With factory headunit or aftermarket? The subwoofer is rated at 250 watts rms @ 4ohm and the amp is rated at 340 watts rms @ 4 ohm. So as long as you dont push it too hard you should be good.

If you are using an aftermarket deck, did you hook up the amp with RCA cables from the HU or take speaker wire level inputs to the amp?

Make sure your ground is good and solid bolt down to chassis. Power wire run on opposite sides of RCA, speaker wire, and remote wire. Should be good!

I'm not a pro at all, but trying to help if i can. Hopefully someone else can pin point it more accurately. Goodluck!

2011 Kona Blue MT82 V6 Mustang Pony Package 3:31 Gear Ratio, Interior Upgrade Pkg, Security & Shaker500/Sync
Mods (in order of installed): AM Bama SCT SF3 Tuner w/ 87 Hybrid Tune, Airaid CAI, Hurst Billet Plus 2 Short Throw Shifter, Lethal O/R H Pipe w/ Stock Exhaust, Blacked-Out Tints on Rear Windows, Full Ceramic Tint on Front Windows, Metra Touchscreen Dash Adaptor, Single DIN Head Unit, 6.5'' Component Speakers Fronts, Stock Rear Speakers, 10'' Sealed Subwoofer, 4ch. and 1ch Amplifier. LED licence plate lights, LED interior dome lights, FRPP/Dynamic shocks and struts, SR Performance lowering springs, GT500 Strut Mounts, BMR Adjustable Panhard Bar, BMR LCA's, BMR Relocation Brackets. Rear Seat Delete.
mtu245 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome