Ford Mustang Forum - View Single Post - JBA longtubes and 11+ Mustangs-Beware
View Single Post
post #69 of (permalink) Old 10-31-2012
tehMoose
Apprentice
 
tehMoose's Avatar
 
Joined: Nov 2010
Location: Austin
Posts: 210
 
Garage
So now that all my parts installed, and the car is finally back up and running. I figure I will throw in my thoughts on the JBA headers and mid pipe.

I'm kind of disappointed in the fitment, I opted with the catted h-pipe (mostly for the added sound dampening). The v-band clamp and the cat will rattle against the body of the car. But I feel this is something that can be remedied. During the initial installation there was what appeared to be enough room that they wouldn't hit, even with slight vibrations. Now, not so much. I feel that after driving it the exhaust has settled in the clamps and what not and shifted a bit. Also I've noticed that the collectors/mid pipe hang below the rest of the car, and will be the first thing to scrape, if that happens. This makes me very weary about lowering the vehicle.

2011 GT Prem - 400a, Brembo Pkg, 3.55s, 6spd
OLD 405rwhp/381rwtq - 12.71 @ 113.13mph, 2.099 60' on stock tires (DA corrected 12.3 @ 116mph)
Mods: Boss 302 bottom end, JPC Stage 1 heads, Boss 302 Manifold/Oil Cooler/Front Fascia/Rear Diffuser, Mishimoto Radiator, Spec Clutch/Flywheel, Airaid CAI, JBA Long Tubes, Pypes Super System, Eibach Pro-Kit, UMI LCA/Relo Brackets/Panhard Bar, GT500 wheels/Nitto NT555 (255/45 F, 285/40 R), Barton Shifter/Bracket, SGII /w blendmount, V1
tehMoose is offline  
 
 
For the best viewing experience please update your browser to Google Chrome