Ford Mustang Forum - View Single Post - JBA longtubes and 11+ Mustangs-Beware
View Single Post
post #71 of (permalink) Old 11-02-2012 Thread Starter
strany
Apprentice
 
strany's Avatar
 
Joined: Aug 2012
Location: Auburn
Posts: 71
 
Mystery sorta solved. I took my car in for a free oil change today at the dealers I purchased from, and told them of my problems with the error codes I was getting from the passengers side front O2 sensor. They told me that the sensor was fried, probably by the extensions JBA included with their kit. The other O2 sensor had been cross threaded and was devoid of most threads. Had to order 2 new sensors and with diagnosis and install my wallet will be lighter $350! Thank you JBA and Casper electronics for the piece of **** extensions that caused me so much grief. Back to the dealer next Tues to have them installed and hopefully my check engine lights issues will be solved. I ought to sue JBA for the money in small claims, still milling that one over. So for anyone else thinking JBA longtubes, DO NOT connect the extensions, unhook the factory harness to extend to the front O2 sensors so you dont potentially fry you new engine

2013 GT, AT, JBA ceramic LT with catted H pipe, resonator delete, GT500 axlebacks. Steeda CAI, Brenspeed tuned, AMR chrome wheels, Cooper
RS3-S tires, Focal door and rear coaxial speakers, Shelby-Kicker door subs

2013 V6 performace pkg, airaid CAI,BBK throttle body, Bama tuned, MTX thunderform, Pioneer Coaxials, alpine KTP-445U amp
The love of my sons life
strany is offline  
 
 
For the best viewing experience please update your browser to Google Chrome