Ford Mustang Forum - View Single Post - emission help
Thread: emission help
View Single Post
post #2 of (permalink) Old 10-10-2005
kscoyote
SHELBY GT 500 Member
V6 Member
 
kscoyote's Avatar
 
Joined: Aug 2002
Location: Topeka
Posts: 11,432
 
Quote:
Originally Posted by shock400
Looking for anyone with emissions knowledge.

Subject: 99 3.8l 96660 miles

problem: AIR Pump- has been replaced with a used one.

Engine light will not go out unless reset by batttery disconnection. Unfortunately light will only stay out for about a day, then comes back on, emission test today failed due to lack of run time from battery disconnection. Inspector states car needs to be run for three days with out power interruption. This is a PA state emission inspection.

Anyone in the Pottstown, PA area that might know or maybe need to get a better look at it is welcome.
I'm not sure what the question is, but I think it has to do with the CEL?

Did you check to make sure the used pump worked?


Woe to him who builds his palace by unrighteousness,his upper rooms by injustice,making his countrymen work for nothing...Does it make you a king to have more and more cedar?Did not your father have food and drink?He did what was right and just,so all went well with him. He defended the cause of the poor and needy,and so all went well...But your eyes and your heart are set only on dishonest gain,on shedding innocent blood and on oppression and extortion. Jer 22:13, 15-17
kscoyote is offline  
 
 
For the best viewing experience please update your browser to Google Chrome