vacuum hose is closing? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-28-2011 Thread Starter
Apprentice
 
Bangii '03's Avatar
 
Joined: Jan 2010
Location: Toronto
Posts: 152
 
Exclamation vacuum hose is closing?

my vacuum hose that connects to my plenum is so worn out that when the vehicle is running the hose closes on itself almost completely. It is the 90 joint which is a couple inches long that is worn out, the inside looks even worse. I was wondering where and what i could buy to replace (i aleady tried 2 ford dealerships and they said that piece has been discontinued )

Couple concerns:
-I don't want to buy something that ends up breaking down and shooting debris in my engine.
-Also, it is strong enough to stay open when the vehicle is on and the vacuum is running.


2003 GT Fire Red/Beige Conv. 4R70W
-C.A.I., 78mm TB&P, S.F.I UDP, 31 spline 8.8" reared w/ 4.10 gears, LT & Prochamber, Borla S

????
hp (lets find out)
Bangii '03 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-28-2011
BOSS Member
4.6L Member
 
GTRaptor's Avatar
 
Joined: Apr 2002
Location: Mexico
Posts: 4,459
 
Copper tube, easy to bend, will last forever.


Rob Hernandez, AFM co-Founder.
GTRaptor is offline  
post #3 of 5 (permalink) Old 04-28-2011 Thread Starter
Apprentice
 
Bangii '03's Avatar
 
Joined: Jan 2010
Location: Toronto
Posts: 152
 
what do you think i should use to make sure its completely sealed?

2003 GT Fire Red/Beige Conv. 4R70W
-C.A.I., 78mm TB&P, S.F.I UDP, 31 spline 8.8" reared w/ 4.10 gears, LT & Prochamber, Borla S

????
hp (lets find out)
Bangii '03 is offline  
 
post #4 of 5 (permalink) Old 04-29-2011
BOSS Member
4.6L Member
 
GTRaptor's Avatar
 
Joined: Apr 2002
Location: Mexico
Posts: 4,459
 
regular hose clamps, no problem since its only vaccum.

Rob Hernandez, AFM co-Founder.
GTRaptor is offline  
post #5 of 5 (permalink) Old 05-03-2011 Thread Starter
Apprentice
 
Bangii '03's Avatar
 
Joined: Jan 2010
Location: Toronto
Posts: 152
 
1/2 inch copper pipe fit perfect no clamps needed, thanks GTRaptor

2003 GT Fire Red/Beige Conv. 4R70W
-C.A.I., 78mm TB&P, S.F.I UDP, 31 spline 8.8" reared w/ 4.10 gears, LT & Prochamber, Borla S

????
hp (lets find out)
Bangii '03 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1