Throttle Body Intake Whistle - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 12-14-2017 Thread Starter
Rookie
 
bobbydd21's Avatar
 
Joined: Oct 2017
Posts: 17
 
Throttle Body Intake High Pitch Whistle

Ever since I cleaned my throttle body I have this obnoxious high pitch whistle. I only hear the whistle when driving at a certain throttle position (in any gear). I just replaced the throttle body/plenum with the SR combo one, IAC/EGR gaskets, completely removed and reinstalled the intake with all hoses, and replaced the PCV valve/hose. I also made sure all of the hoses near the throttle body are good because at first I thought maybe I hit something when taking the throttle body/intake off.

When replacing the stock plenum, the gasket under the plenum was pretty shot. I replaced this with a new felpro one HOPING this was the issue. Nope, still got this stupid whistle. I just took out the whole CAI again, used a different filter, tightened up the MAF housing bolts, and redid all the hose clamps. Still didn't fix it. I did notice there is a crack on one of the bolt holes of the MAF housing. It still tightens down, but you can definitely see its cracked. I doubt this would be causing the issue though.

Here's a video of the sound. It's more prominent in person since my phone was laying on the seat. You can hear towards the end how I can control the whistle with the throttle. If anyone has any other ideas please let me know!


bobbydd21 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 12-14-2017
GT Member
4.6L Member
S197 Member
 
Dana W's Avatar
 
Joined: Jul 2009
Location: Oviedo FLA
Posts: 2,037
 
Probably whistling around the edge of the throttle body blade. Not sure why it would start all of a sudden after cleaning though Maybe the linkage got misaligned somehow. Maybe there is a chunk of debris behind the blade.



130 total pounds of Pitbull ruled by 8 pounds of cat.
Dana W is offline  
post #3 of 13 (permalink) Old 12-14-2017 Thread Starter
Rookie
 
bobbydd21's Avatar
 
Joined: Oct 2017
Posts: 17
 
Quote:
Originally Posted by Dana W View Post
Probably whistling around the edge of the throttle body blade. Not sure why it would start all of a sudden after cleaning though Maybe the linkage got misaligned somehow. Maybe there is a chunk of debris behind the blade.
I just replaced the entire throttle body and plenum with the SR combo one and I still have the whistle :/
bobbydd21 is offline  
 
post #4 of 13 (permalink) Old 12-14-2017
Apprentice
 
dB Racing's Avatar
 
Joined: Mar 2017
Posts: 185
 
Ok, so logically its upstream. It's the connection between the TB and your intake tube/cai
or something else that got misaligned/cracked between the tb and the maf and the filter during the removal/cleaning

Renegade Racing 4.6 SOHC: Cobra Crank, Manley Rods, Coated Diamond Pistons 10.75:1 comp w/valve reliefs, PnP CNCd NPI heads, PI intake, Comp Cams 262ah, Ferrea Valves, 70mm TB, TrickFlow, BBK LT o/r X, SCT, Exedy, FRPP 4.10 rar
2001 GT
dB Racing is offline  
post #5 of 13 (permalink) Old 12-14-2017 Thread Starter
Rookie
 
bobbydd21's Avatar
 
Joined: Oct 2017
Posts: 17
 
Quote:
Originally Posted by dB Racing View Post
Ok, so logically its upstream. It's the connection between the TB and your intake tube/cai
or something else that got misaligned/cracked between the tb and the maf and the filter during the removal/cleaning
That's exactly what I was thinking as well. I've already tried replacing the coupler between the TB and intake tube. Just today I even tried replacing the intake tube itself. The only two things I have not replaced are the coupler between the intake tube and MAF and the PCV hose that runs into the intake tube. Maybe I'll try that tomorrow but I doubt thats the issue.
bobbydd21 is offline  
post #6 of 13 (permalink) Old 12-15-2017
Apprentice
 
dB Racing's Avatar
 
Joined: Mar 2017
Posts: 185
 
Consider also that its not the intake tract but a pulley or something else that modulates with rpm.

Also, how does your pcv hook up to your intake tube? What about the bypass? What about the pcv valve and seals to the camcover and the tube?

Renegade Racing 4.6 SOHC: Cobra Crank, Manley Rods, Coated Diamond Pistons 10.75:1 comp w/valve reliefs, PnP CNCd NPI heads, PI intake, Comp Cams 262ah, Ferrea Valves, 70mm TB, TrickFlow, BBK LT o/r X, SCT, Exedy, FRPP 4.10 rar
2001 GT
dB Racing is offline  
post #7 of 13 (permalink) Old 12-15-2017 Thread Starter
Rookie
 
bobbydd21's Avatar
 
Joined: Oct 2017
Posts: 17
 
Quote:
Originally Posted by dB Racing View Post
Consider also that its not the intake tract but a pulley or something else that modulates with rpm.

Also, how does your pcv hook up to your intake tube? What about the bypass? What about the pcv valve and seals to the camcover and the tube?
It seems too coincidental to not be something with the intake, but I could be wrong. It doesn't really change with RPM but with throttle position. Maybe its not the PCV line, I just heard someone call it that in a video. Its that breather hose that connects to the intake tube. Is that what you are referring too?

Also, here is a much better video to clearly hear the whistle:
bobbydd21 is offline  
post #8 of 13 (permalink) Old 12-15-2017
SHELBY GT 350 Member
Classic Member
4.6L Member
 
SoCal2V's Avatar
 
Joined: Sep 2010
Location: see user name
Posts: 8,705
               
IAC is worth taking a look at.


2001 GT Convertible
/1967 Coupe
All the usual bolt-on's /200 I6, C4

And a few Explorers too... 2008 4.0 XLT 4x2, 1996 XLT 5.0 4x2, 2003 Sport Trac XLT 4.0 4x4
SoCal2V is offline  
post #9 of 13 (permalink) Old 12-15-2017 Thread Starter
Rookie
 
bobbydd21's Avatar
 
Joined: Oct 2017
Posts: 17
 
Quote:
Originally Posted by SoCal2V View Post
IAC is worth taking a look at.
Would that be doing anything when the throttle is open? I thought the valve closes when you apply throttle (I could be wrong).
bobbydd21 is offline  
post #10 of 13 (permalink) Old 12-18-2017 Thread Starter
Rookie
 
bobbydd21's Avatar
 
Joined: Oct 2017
Posts: 17
 
Just changed out the IAC and replaced the hose that connects to the back of the plenum. No luck :/
Anyone else have any other ideas? What are other vacuum lines that I could have hit/cracked when replacing the throttle body? Also, does anyone know where the hose on the back of the plenum goes after the coupler? Looks like it goes into the fender somewhere.
bobbydd21 is offline  
PONY Member
4.6L Member
 
97stangt's Avatar
 
Joined: Jan 2016
Location: Clarksville
Posts: 517
 
Garage
I have the same whistle but ive had it since ive bought the car I always thought it was normal

1997 Mustang Gt auto - White Rose - Custom 2in exhaust with headers and flowmasters and an offroad stock 2.25 in h pipe and custom bent 2.25 catback 3.08 rear end MM caster camber plates installed Kyb gr2s installed Ford racing c springs with polys isos all around SR performance upper and lower poly control arms pi head swap gt500 followers sr cold air intake hand ported stock plenum raxiom smoked halo headlights
97stangt is offline  
post #12 of 13 (permalink) Old 12-19-2017 Thread Starter
Rookie
 
bobbydd21's Avatar
 
Joined: Oct 2017
Posts: 17
 
Quote:
Originally Posted by 97stangt View Post
I have the same whistle but ive had it since ive bought the car I always thought it was normal
Oh really? Thatís actually good to hear thought I was alone haha. Iíve tried everything so Iím guessing itís just the intake sound (although it doesnít sound that normal to me).

Just replaced the IAC. Also took off the vacuum lines that run to the plenum plugged the plenum and it still whistled.
bobbydd21 is offline  
PONY Member
4.6L Member
 
97stangt's Avatar
 
Joined: Jan 2016
Location: Clarksville
Posts: 517
 
Garage
I know how you feel I normally only hear it when I'm driving and at part throttle

1997 Mustang Gt auto - White Rose - Custom 2in exhaust with headers and flowmasters and an offroad stock 2.25 in h pipe and custom bent 2.25 catback 3.08 rear end MM caster camber plates installed Kyb gr2s installed Ford racing c springs with polys isos all around SR performance upper and lower poly control arms pi head swap gt500 followers sr cold air intake hand ported stock plenum raxiom smoked halo headlights
97stangt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1