Spark Plug Problem on a 1999 Mustang GT - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 06-06-2010 Thread Starter
Rookie
4.6L Member
 
chiefshky22's Avatar
 
Joined: Jun 2010
Location: Champaign
Posts: 1
 
Spark Plug Problem on a 1999 Mustang GT

I recently replace my spark plugs in my 99 GT. I was just taking the on bolt out to get the coil off and then taking the plugs out and replacing them. I got 5 done when one of the mounts to the coils broke. I was wondering if i need this because i noticed that after market coils don't even have a way to mount it.
Also i can't get the other two bolts off to get to the last plugs, so i can't replace the last two. Any advise on that?
Last thing is i had to drive the car so i replaced the 6 i could get to and put everything back together, when i started it i can hear a knocking noise like a plug is loose. I used a torque wrench at 12 ft/lbs. Does anyone know what the noise could be?
Any help is great, Thanks.

chiefshky22 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1