heating problems - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 06-27-2010 Thread Starter
Apprentice
 
302mustanglx's Avatar
 
Joined: May 2010
Location: Mesquite
Posts: 148
 
heating problems

i just did a raydiator flush 2 my 5.0 it had water before i have a 180 tstat but my temp on the highway goes more then half and when i get back in town it goes down a bit but still just a little over half is this normal with a 180 tstat or what do u guys think is going on plz help:nogrinner


88 mustang lx bbk longtubes bbk hpipe gt40p heads comp cam pro comp intake manefold 3inch cranck pully msd 6al2 600 holley control arms alumenum d shaft 373 gears drag racing springs
302mustanglx is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1