Ford Mustang Forum - View Single Post - e brake question.....
View Single Post
post #3 of (permalink) Old 06-28-2006
kscoyote
SHELBY GT 500 Member
V6 Member
 
kscoyote's Avatar
 
Joined: Aug 2002
Location: Topeka
Posts: 11,432
 
Quote:
Originally Posted by mayville1
ok i see where the teeth are that pull the cable back. But the (tooth) thing that fits in the gears doesnt go down into them. Does this mean something is broke, do i need a new handle and mechanism thing? Or could it have slipped and can I fix it????/

coyote i need your help!!!!!!! u should no this?????

thanks in advanced!!!
can you take a picture?

The thumb lever may be broken. Do you see anything moving when you press on the lever?
************************************
Usually what happens is that the cable breaks or corrodes from salt/contaminants. There's nothing to pull against the lever so that it can set -no tension.

look underneath the car and see if it's hanging, & if it's not, have someone pull on it underneath the car (in the direction it's supposed to go (don't let em yank it down) and see if that makes a difference.

I haven't had to mess with the parking brake since my 1968 & that had drums -with drums it's a mechanical linkage, & I'm not sure how that would work with discs. So you might want to ask in the regular forum, since it's non V6 specific . ..

Woe to him who builds his palace by unrighteousness,his upper rooms by injustice,making his countrymen work for nothing...Does it make you a king to have more and more cedar?Did not your father have food and drink?He did what was right and just,so all went well with him. He defended the cause of the poor and needy,and so all went well...But your eyes and your heart are set only on dishonest gain,on shedding innocent blood and on oppression and extortion. Jer 22:13, 15-17
kscoyote is offline  
 
 
For the best viewing experience please update your browser to Google Chrome