Transmission interchange(or tech help with AOD) - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 07-30-2005 Thread Starter
 
whitestang89's Avatar
 
Joined: Jul 2005
Posts: 6
 
Exclamation Transmission interchange(or tech help with AOD)

have an 89 LX with 105k miles and an AOD tranny. took out for gas when i put car in park, it made wierd noise and car shut off. would not restart in park, only in neutral. can not put shifter in park, reverse, or 1 with out car shutting off. Thought maybe filter was clogged, but it was clean as was the pan. fluid was like a dark grey color. Wanted to know if i needed a new tranny or if it was an easy fix? also will any other transmissions fit such as out of a lincoln or grand marquis?

whitestang89 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-30-2005
MACH I Member
5.0L Member
 
lxarlo's Avatar
 
Joined: Jan 2005
Location: Huntington Beach
Posts: 2,975
 
Send a message via AIM to lxarlo
you might just have a driveability problem not a trans problem.


Why drive a Prius when you can have a Fiesta!!
lxarlo is offline  
post #3 of 6 (permalink) Old 07-31-2005
Apprentice
5.0L Member
 
LqDFx's Avatar
 
Joined: Jan 2004
Location: Kendallville
Posts: 215
 
Send a message via MSN to LqDFx Send a message via Yahoo to LqDFx
I have a AOD out of a 90 Cougar. That is what is marked on the top of the tranny and what the place I got it from told me it was. It bolted right up to the flywheel and all I had to do was some miner linkage work to get it to function with my stock shifter.

Proud Mustang Owner since 1994
Current Ride:
1990 LX 5.0 - 3G Alt. Upgrade. More to come later!
LqDFx is offline  
 
post #4 of 6 (permalink) Old 08-02-2005
 
macx's Avatar
 
Joined: Oct 2002
Posts: 103
 
Quote:
Originally Posted by whitestang89
have an 89 LX with 105k miles and an AOD tranny. took out for gas when i put car in park, it made wierd noise and car shut off. would not restart in park, only in neutral. can not put shifter in park, reverse, or 1 with out car shutting off. Thought maybe filter was clogged, but it was clean as was the pan. fluid was like a dark grey color. Wanted to know if i needed a new tranny or if it was an easy fix? also will any other transmissions fit such as out of a lincoln or grand marquis?
Sounds like the problem may be with your neutral safety switch.
It's screwed into the driver side of the trans about over where the shift shaft
goes into the case. The switch sits vertically, and has a plug to it with several wires.

Was your car "shutting off" like you turned off the key, or was the engine
killing from the trans being locked up?

If the switch is bad (or loose and out of adjustment), it would kill your ignition.
If the engine is being snubbed, that's a whole nother matter and the trans would
definitely be a rebuild or junk candidate, probly with major internal hard part problems.

Dark grey is not a good color for trans fluid.

Just FYI, here's some info on AOD's

http://www.lincolnsonline.com/article111.html

As far as interchange goes, all AOD's generally interchange, although
you do not want a pre-88 trans, and some Lincoln and light truck and
Crown Vic trans are 1" longer. You also don't want a V6 AOD, and the
91-93 Stang AOD's are good ones to get.

Here's another article with more in depth

(there's an update about to be posted to it)
http://www.lincolnsonline.com/article80.html

and some other tips about AOD's & working with them

http://www.lincolnsonline.com/article48.html
http://www.lincolnsonline.com/article91.html
macx is offline  
post #5 of 6 (permalink) Old 08-02-2005
5.0L Member
 
STINGREY's Avatar
 
Joined: Mar 2004
Posts: 897
 
the convertor is locking,check the tv pressure adjustment.
STINGREY is offline  
post #6 of 6 (permalink) Old 08-13-2005 Thread Starter
 
whitestang89's Avatar
 
Joined: Jul 2005
Posts: 6
 
thanks for all the help

"Was your car "shutting off" like you turned off the key, or was the engine
killing from the trans being locked up?"

Engine was definitely shutting off because of trans
whitestang89 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
AOD transmission cdnpt V6 Tech 7 06-29-2005 10:58 PM
AOD Transmission problem Mustang_B 5.0L Talk 10 05-08-2005 09:26 PM
what is the difference between an AOD and an AODE? purple horse Classic Tech 11 03-13-2005 03:23 AM
Transmission Fluid AOD 5.0L Tech 6 07-21-2003 09:45 PM
AOD Transmission Question 5.0L Tech 6 04-08-2002 05:44 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1