power steering components lat model vs. rock auto - Page 11 - Ford Mustang Forum
Reply
 
LinkBack Thread Tools
MACH I Member
5.0L Member
 
shakerhood's Avatar
 
Joined: Feb 2005
Location: -Southern Ohio
Posts: 3,445
 
Quote:
Originally Posted by whitemare View Post
this is what I got, didn't think it should be that loose.
For some reason I cannot view those, hopefully you figure out where the play is coming from.

shakerhood is offline  
Sponsored Links
Advertisement
 
post #152 of 155 (permalink) Old 06-29-2015 Thread Starter
Apprentice
 
whitemare's Avatar
 
Joined: Apr 2012
Location: dfw
Posts: 181
 
i found the play, it's where the new stub slips into the steering wheel shaft. I tightened the nut/bolt down so tight that the wheel started turning like someone was steering it. it's still loose, if you remember I had that issue with the old mm stub being hard to remove, well this one slid in so easy it would almost fell back out so maybe it still isn't machined right. I'm thinking if maybe I use a bolt the same size as the holes that might stop the slack, maybe shim it too. Also the bolt head is on the concave part so all the clamping force is not be utilized either.

whitemare is offline  
post #153 of 155 (permalink) Old 07-12-2015 Thread Starter
Apprentice
 
whitemare's Avatar
 
Joined: Apr 2012
Location: dfw
Posts: 181
 
hey shaker hood, looks like I finally got my steering play fixed. got a bolt that was next size up from stock and "threaded" into the steering joint and upper steering wheel shaft and no play. Up in air or on ground as soon as I barley turn steering wheel the tire starts to turn, no delay. won't be able to road test until i find the short causing my gauge lights to go out but I think it will be like it should.
whitemare is offline  
 
MACH I Member
5.0L Member
 
shakerhood's Avatar
 
Joined: Feb 2005
Location: -Southern Ohio
Posts: 3,445
 
Good deal, sounds like you got it worked out and will be able to enjoy it now!
shakerhood is offline  
post #155 of 155 (permalink) Old 07-13-2015 Thread Starter
Apprentice
 
whitemare's Avatar
 
Joined: Apr 2012
Location: dfw
Posts: 181
 
I hope so!! thanks for the help!
whitemare is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1