Ford Mustang Forum - View Single Post - 2013 Mustang GT Premium Stereo Install
View Single Post
post #5 of (permalink) Old 09-05-2013
bigbird
PONY Member
 
bigbird's Avatar
 
Joined: Mar 2007
Location: Winnipeg
Posts: 339
 
Angry

Quote:
Originally Posted by alborn98 View Post
I would agree on the bad ground connection. I have the Shaker 500 and installed the Kenwood DNX570HD (2013 model) w/ Maestro RR and have no issues. Sound is better than OEM and so far I love it.

I'm currently using the Metra touch screen dash kit and it's really growing on me, but I would consider switching to the iDatalink dash kit if they ever release the dam thing. Last I heard they were gonna ship in August but it's the end of August and still no update...sigh

Anyway since this post is 4 months old I'm sure you've got this sorted by now but for anyone searching this issue, double check your ground connection!
I too have the DNX570HD and the Metra w/Maestro RR. Quite pleased with the system. The only problem I have is the Garmin map updates are not available for this unit, can't even purchase lifetime updates from Garmin. When and if updates are available, Kenwood wants 99.00 for each update. I am really pissed about this. I bought the unit partly on the strength of the Garmin GPS. IMHO bad customer support. If Kenwood is going to offer Garmin, then do it right. Wish I had gone with a Pioneer now!

2015 Mustang GT 50 Year Anniversary, Ruby Red coupe. Staggered fit 19 inch wheels from American Muscle. Front tires are Sumitomo 245/45 19, rears are Sumitomo 275/40 19. Sound tube deleted, resonator deleted, replaced with h-pipe, Bama tune, custom sub woofer with Rockford Fosgate P3D4 10 inch subwoofer driven by and Alpine MRV 500M mono power amp. Replaced Sync 2 with Sync 3.

Last edited by bigbird; 09-05-2013 at 08:35 PM. Reason: Spelling error
bigbird is offline  
 
 
For the best viewing experience please update your browser to Google Chrome