Ford Mustang Forum - View Single Post - This can't be normal with 3.73s.
View Single Post
post #16 of (permalink) Old 09-27-2013
FordService
Guest
 
FordService's Avatar
 
Posts: n/a
Quote:
Originally Posted by Mpaac View Post
Hey guys I've had this issue going on for a while now with my car since 3.73 gear install. If I'm in traffic and am accelerating slowly the car just loves to jerk hard from first to second and I'm in an automatic. Also on braking you can feel the car clunking back from 2nd to first almost every time. It's almost like you are being kicked forward. At first I thought it was a tune issue but I removed it and still have the same problem. I don't know where to go from here because I was not satisfied with the shops work so don't want to go back to them almost 3 months after install. I'm wondering if this has happened to anyone else and what could be wrong. Another note is that I do not hear any gear whine and under hard acceleration the issue is not as noticeable .
Quote:
Originally Posted by Colby2013 View Post
Very common. All three of mine have jerked, my 13 being the worst.
Hey guys,

I think you should touch base with your Service Manager about this. He/she’ll be able to let you know if work or replacement parts are needed and whether there is coverage available (warranty, recall, etc.). Let me know the outcome.

Quote:
Originally Posted by McCarthy View Post
I'm 100% stock and i get the 1-2 clunk and the 2-1 clunk aswell.
You should also check in with your dealer, McCarthy. If you need further assistance, don’t hesitate to PM FordServiceCA.

Deysha

 
 
 
For the best viewing experience please update your browser to Google Chrome