Ford Mustang Forum - View Single Post - Another rear suspension clunk thread please help
View Single Post
post #15 of (permalink) Old 11-16-2013 Thread Starter
deuce106
Apprentice
 
deuce106's Avatar
 
Joined: Mar 2012
Location: los angeles
Posts: 118
 
Quote:
Originally Posted by Raider Ritchie View Post
Hey Deuce106, were you ever able to figure out what it was? It sounds like I have the EXACT same problem as you. I have SR springs and the J&M pan hard bar as well, so I'm wondering maybe if the SR springs or bar have something to do with it? I'm bringing it in for the dealer to look at but I was hoping that I could get an answer from a forum, since I know some dealers are quick to write it off as aftemarket related and sometimes themselves can't give an accurate diagnosis. You are right, it does take the fun away from driving it. It sounds like there's a tire bouncing around loose in my trunk constantly. I don't really here it while cruising on the freeway, but on uneven streets it gets really bad at times. If I found out before you I'll let you know.
Yes I got it fixed, it turned out to be a bad combination of sway bar and end links. I replaced them with hellwig sway and end links, and also replaced all of the suspension nuts and bolts at the same time. Clunks are now completely gone.


2012 mustang v6 performance package, power mods: airraid intake, borla s-type exhaust, appearance mods: saleen front grille, hood spears, roush side spliters, 2013 tail lights, retro fitted head lights with led and hid, shorty antena, black deck lid, gt500 steering wheel, oem take off leather seats, retro black shift knob, suspension mods: koni shocks/struts, sr springs, gt500 top mounts, panhard bar, lca.
1994 mustang gt 5.0
deuce106 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome