Ford Mustang Forum - View Single Post - ABS and Traction Control Lights On
View Single Post
post #6 of (permalink) Old 02-12-2014
FordService
Guest
 
FordService's Avatar
 
Posts: n/a
Quote:
Originally Posted by lilmonte1 View Post
I have a 2012 V6 that has had intermittent traction control issues since 9000 miles, it now has 54,000. Traction Control light illuminations and engages ABS system while driving. It typically happens between 30 -40 mph while driving straight down the road. A few occasions while turning left onto freeway on ramps. I live in Phoenix so it never is wet here to have tire spin from wet surfaces. One time it also illuminated the "Service Advance Trac". The dealer said codes are non specific and can not figure it out. They are guessing speed sensor or Yaw (?) sensor but wont replace without a definitive diagnosis. Last week when it occurred it completely locked the brakes up and I could not go over 20 mph. Anyone else with this problem? I have wrecked the car into a curb once while it was doing it and now with brakes locking up while going down the road I am desperate to find a solution before my car kills me.
Hello lilmonte1,

Welcome to the forum! My name is Deysha with Ford Service and Id like to get this escalated for you. Please, PM me with your VIN, dealer, mileage, full name, and best daytime number so I can help.

Quote:
Originally Posted by Ltngdrvr View Post
Well, it sounds like the dealer has zeroed in on the issue and now they just need to act. ...

You can contact Ford customer service and get them involved, maybe they can get the dealer moving since it is definitely a safety issue.
Quote:
Originally Posted by 5.0 Coyote View Post
Contact DEYSHA at Ford Customer Service ( on this site ) have her look into this problem for you,she has helped many of us with out problems,give her the info she requests from you.
Thanks for the support, guys!

Deysha
 
 
 
For the best viewing experience please update your browser to Google Chrome