Ford Mustang Forum - View Single Post - Couple of interesting problems
View Single Post
post #8 of (permalink) Old 12-18-2015
cman
GT Member
 
cman's Avatar
 
Joined: Feb 2007
Location: Chesteremere
Posts: 1,162
 
I find it best to print off the TSB and hand it to the dealer's service person and say "perform this please". This usually takes care of the usual blank stare as if they have no idea what I'm talking about.

As for the chirp. I did have a similar issue with my 05 GT. It seemed to only happen when going over small sharp bumps and it drove me nuts for about three months until one day I got caught driving in the rain, something I almost never do, and the chirp went away. I waited for it to come back once everything dried out, then I sprayed a shot WD at the lower shock bushings and bolts....noise stopped and has not come back for more than a year. Not saying this is your issue, but might be worth a try.

2005 black GT premium (5spd) / GT500 front LCA/upper strut mounts / Koni Adjustable (yellow)shocks with Roush Springs / FRPP 4:10 rear gear / BMR rear UCA/LCA+relocation brackets / MGW Shifter / Bassani axle backs / Cervinis heat extractor hood and Ducktail spoiler / Carroll Shelby CS69 20x9/20x10 wheels / MSD Blaster 2 coils / Roush TVS2300 Supercharger+Brenspeed 560R upgrade / Exedy Mach 500 Stage 3 Clutch / Exedy lightweight flywheel / SR Performance braided stainless clutch Line / Afco Dual Fan Heat Exchanger upgrade / JLT Catch Can / Axle Exchange one piece aluminum DS / Silly grin on my face every time I turn the key.
cman is offline  
 
 
For the best viewing experience please update your browser to Google Chrome