Ford Mustang Forum - View Single Post - 2013 with "bbq tick" questions.....
View Single Post
post #10 of (permalink) Old 01-07-2016
cman
GT Member
 
cman's Avatar
 
Joined: Feb 2007
Location: Chesteremere
Posts: 1,162
 
Quote:
Originally Posted by zinc03svt View Post
Op, try putting in a bottle of hyperlube zinc replacement additive into your oil. I swear by this stuff. I actually run 2 bottles, ford racing oil filter, and the 5-20w ford semi at every oil change. I have the tech prefill the filter and prime the oil system (gas pedal and brake to floor at ignition 4-5 seconds) before start up. Car uses zero oil and motor is as quiet (mechanically) as a mouse fart. Been using this zinc replacement since 3k miles and car now has just over 8k now. KetJenLube 135 is the cats ass. Research it. Good luck.
Has there been any negative effects in regards to the proper operation of the VVT system in these engines when using these zinc additives.

2005 black GT premium (5spd) / GT500 front LCA/upper strut mounts / Koni Adjustable (yellow)shocks with Roush Springs / FRPP 4:10 rear gear / BMR rear UCA/LCA+relocation brackets / MGW Shifter / Bassani axle backs / Cervinis heat extractor hood and Ducktail spoiler / Carroll Shelby CS69 20x9/20x10 wheels / MSD Blaster 2 coils / Roush TVS2300 Supercharger+Brenspeed 560R upgrade / Exedy Mach 500 Stage 3 Clutch / Exedy lightweight flywheel / SR Performance braided stainless clutch Line / Afco Dual Fan Heat Exchanger upgrade / JLT Catch Can / Axle Exchange one piece aluminum DS / Silly grin on my face every time I turn the key.
cman is offline  
 
 
For the best viewing experience please update your browser to Google Chrome