2007 Mustang, Shaker 500 Question - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 04-12-2008 Thread Starter
 
axlshaft's Avatar
 
Joined: Apr 2008
Posts: 4
 
Question 2007 Mustang, Shaker 500 Question

Hi All, I just got my '07 Mustang back from the collision shop (see the introductions section), my car was vandalized and the bums smashed my radio. The shop put in a new one and I have a couple of questions.

The new radio has chrome rings around the buttons and knobs where my original radio did not. What is this from? It says Shaker 500 on it and looks identical to the original minus the chrome.

The speed volume does not work.

There is no night time illumination. I can't recall if the original radio had it or not, I would think so since you can't see the buttons at night.

What did the shop do wrong? did they give me a bum radio or F something else up? I know there is a Smart Junction Box involved.

Any help / suggestions would be appreciated.

Thanks, -Ken

axlshaft is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-12-2008
PONY Member
S197 Member
 
bobrickert's Avatar
 
Joined: Dec 2004
Location: Pasadena
Posts: 534
 
first i would check the brightnes for the interior lights
if its not turned up the radio will be dim
i think the chrome bezels are new for 2008


2006 Torch Red GT 5 speed Black Leather Shaker Hood Scoop CAI black spoiler mirror covers shorty antenna black billett fuel door mustang license plate brackets
bobrickert is offline  
post #3 of 10 (permalink) Old 04-12-2008
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 72,881
                 
Send a message via Yahoo to stlwagon
The chrome is in-fact a new thing. There was some discussion on that in an earlier thread.

1965 Mustang Coupe
stlwagon is offline  
 
post #4 of 10 (permalink) Old 04-12-2008 Thread Starter
 
axlshaft's Avatar
 
Joined: Apr 2008
Posts: 4
 
Shaker 500 Question

So Would it be correct to assume this is a 2008 radio then?

I forgot to say my other dash lights are fine and they will vary in intensity with the dimmer.
axlshaft is offline  
post #5 of 10 (permalink) Old 04-12-2008
Apprentice
 
Alfaduetto's Avatar
 
Joined: Jul 2007
Location: Greeneville
Posts: 160
 
Pinouts

They may have bent some pins or didn't get the J1 plug seated all the way.
Attached is a link to where the wire go, look at illumination pins. There is always the fuse check route.

http://www.cherod.com/mustang/HowTo/Shaker500.pdf

I'm still trying to determine if the radio itself is any different between the 500 and 1000, other than the face script. It looks like the trunk full of junk does all the thumper stuff and not the radio itself. Anybody know what the differences are? I bought a 1000 on Ebay before I even got the car. They look the same as to connections and layout.
Alfaduetto is offline  
post #6 of 10 (permalink) Old 04-12-2008
PONY Member
S197 Member
 
snowboarder7710's Avatar
 
Joined: May 2007
Location: Rancho Cucamonga
Posts: 331
 
thats weird because in my 07, my shaker 500 radio never had the speed volume working since the day i drove it off the lot. i thought about bringing it back but i tossed in a nav unit instead. the illumination and speed sense inputs on the new mustangs run through a data wire because an illumination wire or speed wire does not exist on the harness. i tested for both when i installed my nav. your smart junction box may have to be updated in order to work with an 08 radio.
snowboarder7710 is offline  
post #7 of 10 (permalink) Old 04-13-2008
PONY Member
S197 Member
 
GoStang's Avatar
 
Joined: Apr 2008
Location: Lincoln
Posts: 362
 
To be honest. I would dump the Shaker 500 with chrome or no chrome and buy a new head unit w/nav. The Eclipse AVN 5500 or 6600 are great units. A real good touch to the inside of the Stang.

Steeda CAI W/93 SCT Tune, Steeda CMDP, Steeda UDP, Steeda LCA, Steeda UCA, Steeda Sport Springs, Steeda Panhard Bar & Brace, Steeda Hood Strut Mounts, Steeda adjustable Camber Plates, Tokico D-Specs, G2 Painted Calipers,Sequentail Tail Lights, Magnaflow Free-Flo Cats W/Exhaust, Homelink Self Dimming Rear Veiw Mirror W/ Garage Door Opener, Compass & Temp, Eclipse AVN 5510 Head Unit W/ Nav, Chrome BBK Plenum Cover and various Dress-up Items.
GoStang is offline  
post #8 of 10 (permalink) Old 04-13-2008
GT Member
S197 Member
 
FuzzyDice's Avatar
 
Joined: Mar 2007
Location: Enfield
Posts: 2,437
 
Send a message via Yahoo to FuzzyDice
Quote:
Originally Posted by GoStang View Post
To be honest. I would dump the Shaker 500 with chrome or no chrome and buy a new head unit w/nav. The Eclipse AVN 5500 or 6600 are great units. A real good touch to the inside of the Stang.
I still firmly believe that spending money on a head unit will give you the least bang for the buck. Take the money you would spend on a top of the line head until and put it toward a new outboard amp and new speakers....and the difference will be unreal. Unless you want a bunch of bells and whistles the stock head unit is fine when used in unison with an upgraded amp and speakers.

The stock system is better than most stock systems anyway in my opinion.

2007 GT convertible - black 5 speed MT: charcoal aluminum panel, black/dove int, anti-theft, cloth top, GT appearance pkg, MODS - MGW shifter, CDC Conv Light Bar, Pony 12V plug, Shelby Hood Pins, Steeda Strut Tower Brace, Steeda Strut Tower Covers, FRPP GTA's, CDC Classic chin spoiler, GT500 spoiler, Agent47 Mirrors, 18" Chrome DD bullitt rims/Continental tires, C&L CAI, Infinity speakers, RoadWire 2-tone leather interior, 4.6 badges, Dyno Tune-Mongillo Motors-New Haven-CT-301 rwhp/297 rwt
FuzzyDice is offline  
post #9 of 10 (permalink) Old 04-26-2008 Thread Starter
 
axlshaft's Avatar
 
Joined: Apr 2008
Posts: 4
 
It's Fixed

The radio is now working properly. Aparently it had to be programed by a dealer after it was installed, something the Collision shop did not know.
axlshaft is offline  
Rookie
 
skygremlin's Avatar
 
Joined: Jun 2006
Location: Huntington Beach
Posts: 24
 
Similar Shaker issue

I have a similar issue... I've got an '07 convertable with a a Shaker 500. Everything was working fine until I replaced the battery now it seems the menu is different.
- No Speed vol option at all. Was there before
- I have an option that displays the call numbers of the radio stations I'm listening to (this could have been there before just never noticed it)
- The lights on the buttons don't work
- And when I hit the Aux button it says No Aux Available (or something like that) That was working before with my IPOD

Anybody have any ideas??? I would rather not take it back to any dealership if necessary...

I did check the fuses under the hood... Didn't look at any fuses inside yet..

thanx all

Last edited by skygremlin; 04-30-2008 at 01:08 AM. Reason: added more description
skygremlin is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2005+ Mustang GT... Are aftermarket cams worth it ? MexGT 2005-2010 Mustang Talk 75 09-25-2009 10:40 AM
2000 Mustang GT... What headers and exhaust would be best for me? RickyCee 4.6L Tech 16 03-27-2009 11:05 AM
Ordered 4.10s for my 2000 Mustang GT... A few questions about install dawrr 4.6L Tech 16 10-07-2007 06:55 PM
1997 Mustang GT with Vortech supercharger oiling question Nicks79 4.6L Tech 23 09-27-2007 01:43 PM
2007 Mustang GT exhaust... Question about mid-pipes srt2stang725 2005-2010 Mustang Talk 16 09-02-2007 09:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1