99 Mustang Radio Issues - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 12-28-2011 Thread Starter
Rookie
 
relentless's Avatar
 
Joined: Dec 2010
Location: Oklahoma City
Posts: 11
 
99 Mustang Radio Issues

My factory radio in my 99 Mustang is giving me issues. I will randomly come on and go off and it is becoming more frequent. I pulled out the radio and checked the wires and I discovered if I moved the wire harness that has the power, ground and speaker wires the head unit will power on and off. So im guessing there is an issue with that connector. Is there a place to buy the factory wire harneess and connector that plugs in to the back of the factory stereo and if so where can I get one. I don't want to upgrade to an aftermarket stereo. The factory headunit has a cassette and below the stereo it has a factory cd player.

relentless is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-28-2011
Apprentice
 
01stangman's Avatar
 
Joined: Dec 2010
Location: washington
Posts: 169
 
I'm pretty sure the radio does not have the plug in harness on the back of it. If I were you, and this just me talking, I myself would just bypass the harness and use those round male-female connectors, if you know what I'm talking about here.... At least you'd have a good connection then


Thrush welded mufflers, Flow Master H-pipe. CAI. Shorty headers. Waiting to get 3.73 gears, body kit.....And wheels....
01stangman is offline  
post #3 of 3 (permalink) Old 12-28-2011 Thread Starter
Rookie
 
relentless's Avatar
 
Joined: Dec 2010
Location: Oklahoma City
Posts: 11
 
I really would like to find the factory wire harness with the connector so i could cut the old factory harness and connector off, then splice the new factory wire harness and connector on. I have a feeling that the problem is one of the wires that is terminated inside the grey connector that plugs into the back of the radio. Because when I move the wires close to the grey termination thats when the radio powers on and off. Its strange because if you have the dash lights on (when you have your parking lamps or headlights on) the radio and cd player illuminate but the radio and cd play do not come on until you mess with that wire harness on the back of the radio.
relentless is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1