1995 mustang speakers quit working - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 07-08-2012 Thread Starter
Rookie
 
sharonandjohn's Avatar
 
Joined: Jul 2012
Location: Mesa
Posts: 1
 
1995 mustang speakers quit working

was in a real hurry bad batterry hooked up battery backwards for 1 second now speakers dont work checked all fuses and replaced bad ones book says there are circuit breakers did i blow a breaker or fry the amp or ? thanks in advance for help


Last edited by sharonandjohn; 07-08-2012 at 09:37 PM. Reason: spacing
sharonandjohn is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-11-2012
Rookie
 
AccentGlow's Avatar
 
Joined: Jul 2012
Location: South East
Posts: 6
 
You changed out fuses #8 and #11? You may have fried an amp...

AccentGlow is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1