Mach 460 amp not coming on - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 12-26-2012 Thread Starter
Rookie
 
qtownhb's Avatar
 
Joined: Dec 2012
Location: Philly
Posts: 4
 
Mach 460 amp not coming on

I got a 94 Mustang convertible with a stock Mach 460 stereo. Got a new head unit and tried to put it in. I got no power out of the amp, meaning i could hear the radio, but had to turn the volume all the way up.
So I put the old stock head unit back in, and same problem. Also tried another stock head unit and it too plays music, but have to turn the volume way up.
I assume I blew a fuse to the amp or something. The only fuse I know of was the main one, but since the radio works, I didnt think it was bad.

Thoughts???? Thanks!

qtownhb is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-28-2012 Thread Starter
Rookie
 
qtownhb's Avatar
 
Joined: Dec 2012
Location: Philly
Posts: 4
 
Unhappy

I went over all the fuses again with my volt meter. Checked wires and grounds. Still no amp power. I'm wondering if I fried the amp somehow.

qtownhb is offline  
post #3 of 4 (permalink) Old 01-01-2013
Apprentice
 
mr_marcus478's Avatar
 
Joined: Feb 2012
Location: Americus
Posts: 120
 
A blown fuse i dont think you would hear anyting. What connector do you have? The 1 with 4 rca's to use the stock amps or do you have a black connector with 8 speaker wires u connect to headunit harness?
mr_marcus478 is offline  
 
post #4 of 4 (permalink) Old 01-15-2013
MACH I Member
V6 Member
 
Derfdog15's Avatar
 
Joined: Apr 2010
Location: Fort Pierce
Posts: 2,882
 
Send a message via MSN to Derfdog15 Send a message via Yahoo to Derfdog15
I have always heard that when you go to aftermarket from mach 460/1000 you are supposed to just remove the mach part of the system and use the headunit as the amp... might be wrong though.

2003 Redfire V6,
Show: Smoked everything, cobra front bumper, gt rear bumper, rear decklid and lower valence blackout with black mustang letters, 5% rear front 15%, black 98 Cobra rims front, 95 Cobra R rear black with chrome lip, black scoops and spoiler and exhaust tips

Go: CAI, True Duals with flowmaster super 44's, Bama Tune, full suspension (lowered, 8.8, 4.10s, UCA, LCA, springs, CC plates)
Derfdog15 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1