1996 Mustang V6 Check Engine Light On - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 02-19-2013 Thread Starter
Rookie
 
Tony85's Avatar
 
Joined: Feb 2013
Location: Pelzer
Posts: 8
 
1996 Mustang V6 Check Engine Light On

We have a 1996 Mustang V6..when we bought the car the check engine light was not on..after about 2 weeks it came on...I have had a guy work on it several times..they have put a new Purge Valve on it the first time. That is what the computer stated was wrong..plus several new hoses. Now the light come on and will stay on for 10 miles or so and go off...then come back on..it has stay on for a day and went off..everytime I take it back the error code is P1443. They say its in the fuel vaccum system. Anyone had this problem or know how to repair it?

Tony85 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-19-2013
Rookie
 
arnoldo3's Avatar
 
Joined: Dec 2012
Location: palm springs
Posts: 7
 
could be electrical could be your gas cap that needs to be replaced broken charcoal canister broken vacuum lines from gas tank to canister and from canister to purge solenoid

arnoldo3 is offline  
post #3 of 5 (permalink) Old 02-19-2013 Thread Starter
Rookie
 
Tony85's Avatar
 
Joined: Feb 2013
Location: Pelzer
Posts: 8
 
thank you for the help.
Tony85 is offline  
 
post #4 of 5 (permalink) Old 02-27-2013
PONY Member
4.6L Member
 
4.6StangRage's Avatar
 
Joined: Apr 2006
Location: Jamestown
Posts: 256
 
If you can have someone do a smoke test on your EVAP system because you may have a leak which could throw off the codes. The fact that it throws off codes means that the readings of the input devices read out of what should be normal or acceptable. It could be more than one thing causing it so I would be careful about throwing parts at it because that can get expensive real fast. Btw there could be a TSB on it also.
4.6StangRage is offline  
post #5 of 5 (permalink) Old 03-11-2013 Thread Starter
Rookie
 
Tony85's Avatar
 
Joined: Feb 2013
Location: Pelzer
Posts: 8
 
We found what was wrong. My model has to vaccum fuel values..was told by a Ford dealer 90% of the time when you replace one you have to replace the other. We did and now the light is off. Thank you for the help
Tony85 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1