Another ADS/Maestro Kenwood Install - Page 2 - Ford Mustang Forum
Reply
 
LinkBack Thread Tools
Apprentice
 
5.0_SD's Avatar
 
Joined: Jul 2011
Location: Central, FL via San Diego
Posts: 171
 
Some pics of everything including GPS antennae mounted on the dash in front of the light sensor, Escort live control mounted in the open area below the radio, various shots of the display, sub box and subs, and the viper alarm antennae mounted on the A pillar. Sorry that some don't look so good, I only have a cell phone for pics.

Attached Thumbnails
Click image for larger version

Name:	IMG_5564.jpg
Views:	660
Size:	413.9 KB
ID:	324017   Click image for larger version

Name:	IMG_5565.jpg
Views:	537
Size:	568.6 KB
ID:	324025   Click image for larger version

Name:	IMG_5566.jpg
Views:	472
Size:	540.3 KB
ID:	324033   Click image for larger version

Name:	IMG_5567.jpg
Views:	2405
Size:	418.5 KB
ID:	324041   Click image for larger version

Name:	IMG_5568.jpg
Views:	1259
Size:	554.6 KB
ID:	324049  

Click image for larger version

Name:	IMG_5571.jpg
Views:	569
Size:	525.4 KB
ID:	324057   Click image for larger version

Name:	IMG_5573.jpg
Views:	521
Size:	330.1 KB
ID:	324065   Click image for larger version

Name:	IMG_5574.jpg
Views:	884
Size:	566.2 KB
ID:	324073  

1997 Pacific Green Mustang Cobra...long gone
2014 GT SGM Track Pack 6MT, Recaro's, JLT Catchcan, Kenwood DNX890HD, Maestro MUS1, Maestro RR iDataLink, 2-JL 10W1V3, 4-JL C2570X, JL XD6006, Custom Sub Enclosure
Not yet installed: ARH LT's, Borla OAP's, Borla S, a crap-ton of BMR stuff when they are ready, Forgestar F14's or CF-5's, some form of Coil Overs
5.0_SD is offline  
Sponsored Links
Advertisement
 
PONY Member
 
bigbird's Avatar
 
Joined: Mar 2007
Location: Winnipeg
Posts: 339
 
I had a Metra 99-5286 installed. Worked well but I hated the fact it was hard to use because it was mounted so low in the dash. I installed the MUS1 kit, much better in that regard. Really like the MUS1. How ever, if the Radio is off, there is no access to the climate controls. If my Kenwood craps out in the winter I will freeze my assets!

My Metra is for sale, (cheap) - needs the RR(SR).


2015 Mustang GT 50 Year Anniversary, Ruby Red coupe. Staggered fit 19 inch wheels from American Muscle. Front tires are Sumitomo 245/45 19, rears are Sumitomo 275/40 19. Sound tube deleted, resonator deleted, replaced with h-pipe, Bama tune, custom sub woofer with Rockford Fosgate P3D4 10 inch subwoofer driven by and Alpine MRV 500M mono power amp. Replaced Sync 2 with Sync 3.

Last edited by bigbird; 03-16-2014 at 12:30 PM. Reason: Mistakes
bigbird is offline  
PONY Member
 
bigbird's Avatar
 
Joined: Mar 2007
Location: Winnipeg
Posts: 339
 
Quote:
Originally Posted by 5.0_SD View Post
Some pics of everything including GPS antennae mounted on the dash in front of the light sensor, Escort live control mounted in the open area below the radio, various shots of the display, sub box and subs, and the viper alarm antennae mounted on the A pillar. Sorry that some don't look so good, I only have a cell phone for pics.
I mounted my GPS antennae under the dash centered near the base of the windshield. Nice and clean and out of sight, works great.

2015 Mustang GT 50 Year Anniversary, Ruby Red coupe. Staggered fit 19 inch wheels from American Muscle. Front tires are Sumitomo 245/45 19, rears are Sumitomo 275/40 19. Sound tube deleted, resonator deleted, replaced with h-pipe, Bama tune, custom sub woofer with Rockford Fosgate P3D4 10 inch subwoofer driven by and Alpine MRV 500M mono power amp. Replaced Sync 2 with Sync 3.
bigbird is offline  
 
Apprentice
 
sdheath's Avatar
 
Joined: Nov 2013
Location: Simsbury
Posts: 61
 
Quote:
Originally Posted by bigbird View Post
I mounted my GPS antennae under the dash centered near the base of the windshield. Nice and clean and out of sight, works great.
+1 here. I just finished installing my system and I love the antenna being completely out of sight. But because it's right under the plastic dash it works perfectly well.

--
Steve
2011 3.7 Convertible, K&N Typhoon CAI, Bama SCT Tune
sdheath is offline  
post #20 of 38 (permalink) Old 03-19-2014 Thread Starter
GT Member
Classic Member
S197 Member
 
ChiZ_65's Avatar
 
Joined: Jan 2011
Location: Streamwood
Posts: 1,094
 
5.0_SD pretty much answered everything. The clock is small on the head-unit (wish it was up on the factory LCD)...And it is tough sometimes manipulating the climate controls when driving. You have to continually tap the "<" or ">" buttons on the screen in order for the climate to change for colder or warm. It'd be way easier if you could just hold them down, or put your finger on the actual temperature bar and drag it back and forth to the temperature you want. Knobs are way easier to be honest and I kinda wish I had them....The GPS is awesome. The CD player and EQ equalizer are great. This radio has a great sound to it. The HD radio option is kind of crappy though. I used that crab adapter to hook it up to my stock antenna and the radio gets bad reception. Worse than stock. I have a shorty antenna but that never affected the stock head unit.

My DNX890HD is a refurbished model. If you see my earlier posts, I had some issues and I'm on my second one. Well, yesterday I had a bit of a scare. The touch screen froze on me just like my previous unit was doing. I turned the car on, it would power up, radio would kick on, but then the screen was unresponsive. The volume buttons unresponsive. Only the power button worked (radio was still playing). Every time I restarted the unit the same thing would happen. Screen would freeze after 20 seconds or so of being on. I even reset the unit, but the same thing happened. So, I drove to the grocery store and went shopping. Came out, turned the car on, and the radio was fine. Didn't freeze and I could navigate through everything.... .....I'm pretty close to pulling the plug on this whole thing and installing my stock equipment.

-2011 GT , 6AT, ROUSH TVS 2300 Phase 3 Supercharger w/ CAI, 82mm Pully, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo Cats., Bassani Cat-Back Xhaust, Eibach Pro Suspension, J&M Panhard bar, BMR LCAs, BRENSPEED Tuned...(More in profile)
-1965 Fastback "A-Code" 2+2 , 289 4bbl Edlebrock Performance, Ravin Exhaust..
-1970 BOSS 302 - Dearborn built, Numbers matching 302 engine bored .030 over and stroked to 331. Grabber Blue
ChiZ_65 is offline  
PONY Member
 
bigbird's Avatar
 
Joined: Mar 2007
Location: Winnipeg
Posts: 339
 
Quote:
Originally Posted by ChiZ_65 View Post
5.0_SD pretty much answered everything. The clock is small on the head-unit (wish it was up on the factory LCD)...And it is tough sometimes manipulating the climate controls when driving. You have to continually tap the "<" or ">" buttons on the screen in order for the climate to change for colder or warm. It'd be way easier if you could just hold them down, or put your finger on the actual temperature bar and drag it back and forth to the temperature you want. Knobs are way easier to be honest and I kinda wish I had them....The GPS is awesome. The CD player and EQ equalizer are great. This radio has a great sound to it. The HD radio option is kind of crappy though. I used that crab adapter to hook it up to my stock antenna and the radio gets bad reception. Worse than stock. I have a shorty antenna but that never affected the stock head unit.

My DNX890HD is a refurbished model. If you see my earlier posts, I had some issues and I'm on my second one. Well, yesterday I had a bit of a scare. The touch screen froze on me just like my previous unit was doing. I turned the car on, it would power up, radio would kick on, but then the screen was unresponsive. The volume buttons unresponsive. Only the power button worked (radio was still playing). Every time I restarted the unit the same thing would happen. Screen would freeze after 20 seconds or so of being on. I even reset the unit, but the same thing happened. So, I drove to the grocery store and went shopping. Came out, turned the car on, and the radio was fine. Didn't freeze and I could navigate through everything.... .....I'm pretty close to pulling the plug on this whole thing and installing my stock equipment.
My DNX570HD HD radio sounds great. I am quite pleased so far with the functionality of the unit. I agree with the climate control. Be nice to hold it down for fan speed and temp.

2015 Mustang GT 50 Year Anniversary, Ruby Red coupe. Staggered fit 19 inch wheels from American Muscle. Front tires are Sumitomo 245/45 19, rears are Sumitomo 275/40 19. Sound tube deleted, resonator deleted, replaced with h-pipe, Bama tune, custom sub woofer with Rockford Fosgate P3D4 10 inch subwoofer driven by and Alpine MRV 500M mono power amp. Replaced Sync 2 with Sync 3.
bigbird is offline  
Apprentice
 
5.0_SD's Avatar
 
Joined: Jul 2011
Location: Central, FL via San Diego
Posts: 171
 
I echo what Chiz_65 says...the design of the climate control functionality (or disfunctionality) is pretty bad. Having to tap tap tappy sucks, and sometimes it misses a tap! The clock is a little annoying but I'm hoping that part gets fixed in an upcoming firmware update (meaning show it on the upper stock display). You can change a setting somewhere for the HD radio to be analog or something like that...I can't remember where that setting is but it helped my radio station reception quite a bit. I too had it freeze on me once and do the hot air thing once. I also agree that the navigation is really good, the gauge functionality I don't use much, but when I do, it is really nice having that (especially being able to see exact numbers instead of a stick in a range and also seeing individual tire pressure numbers is awesome).

But, after all that, I would NOT go back to stock...the sound and all the other goodies are just so much better with the Kenwood/Maestro/JL stuff in there and out weigh the couple of drawbacks.

ChiZ...stick it out bro, I think once you have all the little bugs worked out you will begin to love the Kenwood/Maestro. It did take me a little while to get used to things and I too felt for a minute there that I should not have gone down the aftermarket sound system road...but I'm glad I did now (other than it taking away, money wise) from doing other mods!).

1997 Pacific Green Mustang Cobra...long gone
2014 GT SGM Track Pack 6MT, Recaro's, JLT Catchcan, Kenwood DNX890HD, Maestro MUS1, Maestro RR iDataLink, 2-JL 10W1V3, 4-JL C2570X, JL XD6006, Custom Sub Enclosure
Not yet installed: ARH LT's, Borla OAP's, Borla S, a crap-ton of BMR stuff when they are ready, Forgestar F14's or CF-5's, some form of Coil Overs
5.0_SD is offline  
post #23 of 38 (permalink) Old 03-21-2014 Thread Starter
GT Member
Classic Member
S197 Member
 
ChiZ_65's Avatar
 
Joined: Jan 2011
Location: Streamwood
Posts: 1,094
 
Quote:
Originally Posted by 5.0_SD View Post
ChiZ...stick it out bro, I think once you have all the little bugs worked out you will begin to love the Kenwood/Maestro. It did take me a little while to get used to things and I too felt for a minute there that I should not have gone down the aftermarket sound system road...but I'm glad I did now (other than it taking away, money wise) from doing other mods!).
lol...ya.. Pro Tip: I find if I rest my wrist on the shifter, I can tap the climate controls (strategically hitting the same spot) while still being able to watch the road. haha

It's been behaving since the other day. I'm going to nose around the HD Radio settings tonight to see If i can find this Analog option you speak of.

-2011 GT , 6AT, ROUSH TVS 2300 Phase 3 Supercharger w/ CAI, 82mm Pully, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo Cats., Bassani Cat-Back Xhaust, Eibach Pro Suspension, J&M Panhard bar, BMR LCAs, BRENSPEED Tuned...(More in profile)
-1965 Fastback "A-Code" 2+2 , 289 4bbl Edlebrock Performance, Ravin Exhaust..
-1970 BOSS 302 - Dearborn built, Numbers matching 302 engine bored .030 over and stroked to 331. Grabber Blue
ChiZ_65 is offline  
Apprentice
 
5.0_SD's Avatar
 
Joined: Jul 2011
Location: Central, FL via San Diego
Posts: 171
 
AHA! You figured out the secret! I do the same as you or I kinda grip the side of the center column and tap with my thumb...so there now you have two ways, lol.

1997 Pacific Green Mustang Cobra...long gone
2014 GT SGM Track Pack 6MT, Recaro's, JLT Catchcan, Kenwood DNX890HD, Maestro MUS1, Maestro RR iDataLink, 2-JL 10W1V3, 4-JL C2570X, JL XD6006, Custom Sub Enclosure
Not yet installed: ARH LT's, Borla OAP's, Borla S, a crap-ton of BMR stuff when they are ready, Forgestar F14's or CF-5's, some form of Coil Overs
5.0_SD is offline  
GT Member
 
scott_0's Avatar
 
Joined: Jun 2011
Location: oxFORD
Posts: 1,870
 
Quote:
Originally Posted by 5.0_SD View Post
The clock is a little annoying but I'm hoping that part gets fixed in an upcoming firmware update (meaning show it on the upper stock display).
no such luck with an update, however the 14' Kenwood models will display the clock in the stock screen

2016 DIB GT Premium A6, Borla S-type axle backs, Rovos Pretoria wheels 20x8.5/20x10, Nitto N555G2 tires 255/35/20 and 275/35/20, Koni yellows, BMR springs
scott_0 is offline  
Apprentice
 
sdheath's Avatar
 
Joined: Nov 2013
Location: Simsbury
Posts: 61
 
Has anyone else noticed Maestro buttons that have a darker blue (closer to purple) than the stock dash lights? I read on another forum that ADS got a bad batch of LEDs and they will swap out the button strip for anyone who has the wrong LEDs. I'm in that group for sure. It's great to see that level of service from ADS.

--
Steve
2011 3.7 Convertible, K&N Typhoon CAI, Bama SCT Tune
sdheath is offline  
post #27 of 38 (permalink) Old 03-29-2014 Thread Starter
GT Member
Classic Member
S197 Member
 
ChiZ_65's Avatar
 
Joined: Jan 2011
Location: Streamwood
Posts: 1,094
 
Quote:
Originally Posted by sdheath View Post
Has anyone else noticed Maestro buttons that have a darker blue (closer to purple) than the stock dash lights? I read on another forum that ADS got a bad batch of LEDs and they will swap out the button strip for anyone who has the wrong LEDs. I'm in that group for sure. It's great to see that level of service from ADS.
Yeah, the dude from Maestro said that they were ordering the correct blue and would send out the proper colors to guys who wanted them. He's over on the Mustang Evolution forums under the name 12V_Guy..

ANYWAY...anyone tried the DVD player yet? Mine will play the DVDs, but no picture. Audio only. The screen stays blue, and it says "Parking Off" in the middle of the screen. Couldn't get picture while in park, driving, or anything...Not sure whats going on.

-2011 GT , 6AT, ROUSH TVS 2300 Phase 3 Supercharger w/ CAI, 82mm Pully, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo Cats., Bassani Cat-Back Xhaust, Eibach Pro Suspension, J&M Panhard bar, BMR LCAs, BRENSPEED Tuned...(More in profile)
-1965 Fastback "A-Code" 2+2 , 289 4bbl Edlebrock Performance, Ravin Exhaust..
-1970 BOSS 302 - Dearborn built, Numbers matching 302 engine bored .030 over and stroked to 331. Grabber Blue
ChiZ_65 is offline  
Apprentice
 
5.0_SD's Avatar
 
Joined: Jul 2011
Location: Central, FL via San Diego
Posts: 171
 
Quote:
Originally Posted by ChiZ_65 View Post
Yeah, the dude from Maestro said that they were ordering the correct blue and would send out the proper colors to guys who wanted them. He's over on the Mustang Evolution forums under the name 12V_Guy..

ANYWAY...anyone tried the DVD player yet? Mine will play the DVDs, but no picture. Audio only. The screen stays blue, and it says "Parking Off" in the middle of the screen. Couldn't get picture while in park, driving, or anything...Not sure whats going on.
That sounds like the wire that tells the unit is in park is not right. Mine plays DVD's while driving or parked since I grounded the parking brake sensor.

1997 Pacific Green Mustang Cobra...long gone
2014 GT SGM Track Pack 6MT, Recaro's, JLT Catchcan, Kenwood DNX890HD, Maestro MUS1, Maestro RR iDataLink, 2-JL 10W1V3, 4-JL C2570X, JL XD6006, Custom Sub Enclosure
Not yet installed: ARH LT's, Borla OAP's, Borla S, a crap-ton of BMR stuff when they are ready, Forgestar F14's or CF-5's, some form of Coil Overs
5.0_SD is offline  
Rookie
 
alborn98's Avatar
 
Joined: Apr 2013
Location: Duluth
Posts: 15
 
Quote:
Originally Posted by sdheath View Post
Has anyone else noticed Maestro buttons that have a darker blue (closer to purple) than the stock dash lights? I read on another forum that ADS got a bad batch of LEDs and they will swap out the button strip for anyone who has the wrong LEDs. I'm in that group for sure. It's great to see that level of service from ADS.
My answer to the darker blue button bar LEDs? ... Change em to RED. BOOM!
Attached Thumbnails
Click image for larger version

Name:	RED LED LIGHT BAR.JPG
Views:	587
Size:	657.2 KB
ID:	343770  

2010 Black GT. Appearance mods only so far. SS center fog grille, DG Customs side and window scoops, SLP Loudmouth axle backs, Roush center console button, Roush white shift knob and boot, Metra touch screen dash kit w/ Kenwood/iDatalink NAV setup to retain SYNC.

NOTE: OEM grille, mufflers, and 401A shift knob w/boot are for sale if interested. PM me an offer.
alborn98 is offline  
PONY Member
 
bigbird's Avatar
 
Joined: Mar 2007
Location: Winnipeg
Posts: 339
 
Quote:
Originally Posted by bigbird View Post
My DNX570HD HD radio sounds great. I am quite pleased so far with the functionality of the unit. I agree with the climate control. Be nice to hold it down for fan speed and temp.
Another feature I really like it the fact that I can see the pressure on all 4 wheels. Much better than the stock "Low tire" warning. Like, which one dude!


2015 Mustang GT 50 Year Anniversary, Ruby Red coupe. Staggered fit 19 inch wheels from American Muscle. Front tires are Sumitomo 245/45 19, rears are Sumitomo 275/40 19. Sound tube deleted, resonator deleted, replaced with h-pipe, Bama tune, custom sub woofer with Rockford Fosgate P3D4 10 inch subwoofer driven by and Alpine MRV 500M mono power amp. Replaced Sync 2 with Sync 3.
bigbird is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1