Installing 2007 GT w/ two 962 & 342 watt amps, Dynamat & Wiring set-up suggestions? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-30-2014 Thread Starter
Rookie
 
redrocker35's Avatar
 
Joined: Dec 2013
Location: Portales
Posts: 48
 
Installing 2007 GT w/ two 962 & 342 watt amps, Dynamat & Wiring set-up suggestions?

I have finally gathered together what I hope to be a near perfect upgrade to my 2007 Mustang GT's audio system. I have read other posts concerning wire gauge and its size necessity once you near 1500 watts rms. The amplifiers are both new Kicker ZX700.5 (class A/B-D ) and CK300.4 (class D) putting out 962 watts and 362 watts rms according to their birth certificates.
The ZX700.5 will be pushing 70 rms each to four Kicker- CS68 6" x 8" Coaxial Speaker @4ohms, as well as close to 150 watts each to two KA-8-WOOFER Shelby Kicker 8", which according to the technicians at Kicker, are long throw 200 watt single voice coil @ 2ohm, which when wired parallel creates a 4 ohm load I believe.
The CK300.4 will be bridged to run 150 rms to a Kicker TCompS 40TCWS104 10" 600W Loaded Subwoofer Box w/ 300 rms. I'll still have two left over channels.
I have decided to use the Kicker ZCK44 4 gauge 4 channel amplifier kit to run power and signal, since its all direct fitted to work with as few connections as possible, anyone have a idea why they discontinued this kit?
Now the million dollar question, whats the bare minimum amount and locations of Dynamat should I address? Is there a quality economy odorless butyl product I should consider?
I'm still using the Shaker 500 for now, and being that there is only going to be 4 RCA jacks gained with the PAC AOEM-FRD24 Radio Amplifier Integration Interface Adapter, with use of it will it create a problem with the radios control (fade, L/R, and Menu) or does the adapter still allow all the Shaker 500 controls to be used?
This is my 1st large install, If anyone has experienced something or along these lines and has something to share or has a opinion, any info would be appreciated...


Last edited by redrocker35; 04-30-2014 at 06:10 PM. Reason: Forgot to add amp kit specs
redrocker35 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1