Driver Side speakers not working? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 02-11-2015 Thread Starter
Rookie
 
Hemoclysm's Avatar
 
Joined: Feb 2015
Location: Roxboro
Posts: 1
 
Driver Side speakers not working?

Hey guys, I'm new here and I'm trying to find a solution as to why the speakers on my drivers side are putting out no sound at all. I've got an aftermarket head unit and speakers all around the car. It's a 1999 base model v6 automatic. I don't think I have the mach 460, but I don't know much about this stuff, so that's kinda why I'm here. The sub and passenger's side speakers are working fine, the sound is coming out great and everything. I've been researching for days and there are a few possibilities as to what the problem could be, but I'd like to get your opinions as well. From what I've gathered, it could be anything from an exposed wire to my own stupidity in letting a friend hook up the head unit (hooked up the wires incorrectly) or it could be the amp ( I think it's an amp, I have no idea. It's a silver box deep behind the head unit inside the dash) Hope you guys can help me Thanks

Hemoclysm is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-11-2015
PONY Member
 
wjbertrand's Avatar
 
Joined: Feb 2014
Location: Ventura
Posts: 657
 
Garage
Forgive me for asking the obvious - have you checked the balance control?


-Jeff-
Ventura, CA
2013 GT Premium Brembo
MGW, Blow Fish, AM Hood Struts
Tinted, Borla Touring AB, ProCal Tune
Full Shelby/Kicker Audio Upgrade
wjbertrand is offline  
post #3 of 3 (permalink) Old 02-13-2015
GT Member
 
6stang02's Avatar
 
Joined: Nov 2014
Location: Fort Worth
Posts: 1,351
 
Garage
+1 to wj. How old is that head unit? When i bought my pos 2000 gt last year the owner apparently punched his head unit and the passenger side would work somewhat and the driver side wouldn't work except for the tweeters. When i installed the new one it worked just fine. I would also look into the wiring. The harnesses should be color coated to somewhat match.

19 GT PP1
65 GT A-Code Mustang 289
66 GT A-Code Mustang 289
6stang02 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1