1967 mustang C4 leaks while dormant - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 10-16-2013 Thread Starter
Rookie
 
Oldmo1967's Avatar
 
Joined: Oct 2013
Location: Colorado Springs
Posts: 3
 
1967 mustang C4 leaks while dormant

I have a 67 Mustang with 289 and C4 trans. Trans has been rebuilt by long standing reputable shop. Have a problem with leaks while parked for a few days. Trans level when cold not running is 4 inches above full mark. Hot and in park level is right at full mark. Car is back in shop now. Rebuild was a complete rebuild, all seals and internal rebuild. Seems this a an ongoing C4 problem with many. Looking for any suggestions as to what is "normal" for my C4?? Level when cold? I understand there is not a "check valve" in these early converters to stop drain back into trans? Leaks only after sitting for a few days in garage. No leaks when driving that show up anywhere under car, or on rear of car. Any suggestions would be very much appreciated to help in diagnose of this type problem.

Oldmo1967 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-17-2013
Rookie
 
MagdaLeno's Avatar
 
Joined: Aug 2013
Location: Houston
Posts: 11
 
wow! I have the same problem... I had the c4 of my 66 rebuilt and it has been leaking trans fluid. Yesterday I took it back to the shop again for the third time hopefully this time they will fix the leak otherwise I will have to take it to a different shop...

MagdaLeno is offline  
post #3 of 4 (permalink) Old 10-17-2013 Thread Starter
Rookie
 
Oldmo1967's Avatar
 
Joined: Oct 2013
Location: Colorado Springs
Posts: 3
 
Third time back for mine also. Shop has installed different types of seals throughout, but it still looks like the very high fill level when cold and sitting is part of the problem. Shop has it for an extended time to monitor the leak and get a better pinpoint on what may be causing. Usually has to sit for a week or so before it leaks. Will post if there are any definite clues as to what is causing it. Trans has a new converter along with the rebuild....pretty much a new trans.
Oldmo1967 is offline  
 
post #4 of 4 (permalink) Old 11-12-2013 Thread Starter
Rookie
 
Oldmo1967's Avatar
 
Joined: Oct 2013
Location: Colorado Springs
Posts: 3
 
Leaking C4 while Idle fixed

I have had the 67 at the Trans shop for almost two weeks. They kept it on a lift idle to see exactly where the trans is leaking. Turns out it is the pan. This is the original pan and has had new gaskets twice since the rebuild. Installed a new deep aluminum heavy duty pan and has been two weeks and no more leakage. Looks like we have a fix!!!!
Oldmo1967 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1