new TC 3000 stall mod , still same time ? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 12-16-2012 Thread Starter
Apprentice
 
281Jimmy's Avatar
 
Joined: Jul 2011
Location: Houston
Posts: 77
 
new TC 3000 stall mod , still same time ?

I added a new TCI 3000 converter , supposed to shave a 1/2 second off my time in the 1/4 , I ran a 13.5 in the summer , it was 62 degrees Friday night and ran the same thing , look at my mods in my sig. what is wrong , besides the tune ?


06 GT ,Auto ,Muthr Thumpr Cams,BBK Shorties, Bassani O/R X Pipe , Bassani SS Axle backs , Bama93+Race Tune , JLT 110mm, BBK 62mm TB ,FRPP 3.73 , TCI 3000 stall, Alum. D.S. ,CMCV Delete Plates , ZEX 100 shot , Cervinis Eleanor Kit , Race Stars 15 x 10 w/ Mickeys 275/60/15 , Eibach Pro kit ,CHE rear upper and lower control arms , J & M Panhard Bar(Adjust.) P/B 60 ft 1.72
281Jimmy is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-17-2012
old_goat
Guest
 
old_goat's Avatar
 
Posts: n/a
Even though I came from the Pontiac stall driven car world, I would guess that your estimate of a half second is being too generous.

On Pontiacs (G8 GT, G8 GXP, 2005-2006 GTO) we were seeing around .3 faster, not anywhere near .5 faster.

Now if some guy was running 13.0 in +2000 DA, then installed a stall then raced again in -200 DA and ran a 12.5, then I could see him losing .5 in the quarter, in this context.

post #3 of 9 (permalink) Old 12-17-2012
MACH I Member
 
stang93mustang's Avatar
 
Joined: Oct 2007
Location: Elgin
Posts: 3,133
 
Could be sort of my situation. I got a new converter and it made only a slight difference because it move my weak link somewhere else. I had decent suspension but now with the new converter that same suspension couldn't handle the hit and now caused wheel spin. Now have to get all new so that it can handle what it's suppose to.

I'm not saying now you need new suspension, just saying things like that happen. You may have a weak link somewhere.

93' LX hatch, 460 w/150 plate, TH400, 9" w/ 3.60 spool. Best (so far!) of [email protected] 146 mph with 1.40 spinning 60' on steel heads
Reese,
Been saying single digit coming for 3 years.....guess I finally made it!
stang93mustang is offline  
 
post #4 of 9 (permalink) Old 12-17-2012 Thread Starter
Apprentice
 
281Jimmy's Avatar
 
Joined: Jul 2011
Location: Houston
Posts: 77
 
Old Goat I think we raced Friday night @ Royal Purple Raceway, I was in the Silver 06 GT with the Cervinis kit , I did race an older man with glasses with a 2013 5.0 blue , anyways I would expect some improvement in my et.,but nothing not even with colder weather.

I did change my shocks from the factory to Eibach pro kit which lowerd the car 1.25 in the front and 1.60 in the rear.

06 GT ,Auto ,Muthr Thumpr Cams,BBK Shorties, Bassani O/R X Pipe , Bassani SS Axle backs , Bama93+Race Tune , JLT 110mm, BBK 62mm TB ,FRPP 3.73 , TCI 3000 stall, Alum. D.S. ,CMCV Delete Plates , ZEX 100 shot , Cervinis Eleanor Kit , Race Stars 15 x 10 w/ Mickeys 275/60/15 , Eibach Pro kit ,CHE rear upper and lower control arms , J & M Panhard Bar(Adjust.) P/B 60 ft 1.72
281Jimmy is offline  
post #5 of 9 (permalink) Old 12-17-2012
MACH I Member
 
stang93mustang's Avatar
 
Joined: Oct 2007
Location: Elgin
Posts: 3,133
 
Quote:
Originally Posted by 281Jimmy View Post
I did change my shocks from the factory to Eibach pro kit which lowerd the car 1.25 in the front and 1.60 in the rear.
Lowered suspension doesn't work well for drag racing scenareos. Make sure you have enuff stroke in the shocks that they are not bottoming out.

93' LX hatch, 460 w/150 plate, TH400, 9" w/ 3.60 spool. Best (so far!) of [email protected] 146 mph with 1.40 spinning 60' on steel heads
Reese,
Been saying single digit coming for 3 years.....guess I finally made it!
stang93mustang is offline  
post #6 of 9 (permalink) Old 12-17-2012
old_goat
Guest
 
old_goat's Avatar
 
Posts: n/a
Quote:
Originally Posted by 281Jimmy View Post
Old Goat I think we raced Friday night @ Royal Purple Raceway, I was in the Silver 06 GT with the Cervinis kit , I did race an older man with glasses with a 2013 5.0 blue , anyways I would expect some improvement in my et.,but nothing not even with colder weather.
Yea, I think we lined 'em up together. I remember racing a silver GT early in the night. I left early due to the impossible conditions and huge crowd that night. My best was a 12.82 and I really wanted to see if I could get a 12.7X before the night was over. The next time I'm at the track, I'll have some minor mods and a FRPP tune.

Jimmy, (I'm also a Jim) you should see a drop in your e.t. with a stall. Was your tune updated? Also, real important, do you have a transmission cooler on your car? If not, you really need to get one installed to handle the heat coming from the transmission on those nights at the track. One of my good friends told me that the 5.0's have a cooler, but I'm not sure about the 4.6's.
post #7 of 9 (permalink) Old 12-17-2012 Thread Starter
Apprentice
 
281Jimmy's Avatar
 
Joined: Jul 2011
Location: Houston
Posts: 77
 
I was still running my old tune , I did not update it until Sunday morning , But from what I here you don't need a tune for the stall, but Mike Wilson from Bama sent me a new one anyways , for all I know It's probably the same tune I already had! LOL ,

I called TCI this morning , they said the stall doesnt eben lock up untill 3000 rpm , I was leaving @ 1,500 and 2,200 and idle ,trying to find a sweet spot. They said to launch @ 3200 and heat up the drag radials real good.

06 GT ,Auto ,Muthr Thumpr Cams,BBK Shorties, Bassani O/R X Pipe , Bassani SS Axle backs , Bama93+Race Tune , JLT 110mm, BBK 62mm TB ,FRPP 3.73 , TCI 3000 stall, Alum. D.S. ,CMCV Delete Plates , ZEX 100 shot , Cervinis Eleanor Kit , Race Stars 15 x 10 w/ Mickeys 275/60/15 , Eibach Pro kit ,CHE rear upper and lower control arms , J & M Panhard Bar(Adjust.) P/B 60 ft 1.72
281Jimmy is offline  
post #8 of 9 (permalink) Old 12-18-2012
old_goat
Guest
 
old_goat's Avatar
 
Posts: n/a
Quote:
Originally Posted by 281Jimmy View Post
They said to launch @ 3200 and heat up the drag radials real good.
Man, I don't know about launching at 3200. That's awful high for an auto.

I think they're too many absolutes when talking about launching a car. Weather, track location and prep, how your car reacts to mods.

Below is a video of my old G8 GXP with a 3200 yank stall. I couldn't launch it over 2200 because I would blow the run, even after heating up the Nitto NT05R drag radials really good, I couldn't get out of the hole due to excessive wheel spin. The one thing about this video is that I learned something else about my car. I was chasing 11's with just bolt ons (3200 stall, tune by Patrick G in Victoria Tx, long tubes, cai, and the Nitto drag radials) and thought I had found my sweet spot to launch the car, which was around 2000. After staging, I would rev it up to 2000, then haul azz on the last amber. If you watch this video closely, you will see that for some reason or another (Royal Purple Houston) they gave me a pro light, and I had to leave from off idle. All of my high 11's (5 of them, best of 11.91) came from leaving off idle.

I think 3200 is way too much and remember, spinning ain't winning. Get your tune updated, go to the track and don't worry about any car but your own, and find that sweet spot. If you have Nitto's, then you really need to heat them up for them to hook, but trust me, the Nitto's will hook if heated up properly.

Just remember, off idle may be your sweet spot.........but it takes trial and error to find it, and just because 2000 is your sweet spot on night, doesn't mean it will be your sweet spot the next week.

I tried to link a video, but after the video played, it went to a menu with more videos. I hate it when they make changes and you can't link a video. It could be because HTML is off. PM me if you want to view the video and I'll send you a link.
post #9 of 9 (permalink) Old 12-18-2012
MACH I Member
 
stang93mustang's Avatar
 
Joined: Oct 2007
Location: Elgin
Posts: 3,133
 
Oldgoat I agree with you on leaving off idle. Before my new converter, I would leave just above idle instead of trying to torque it up before.

With my new one......it is a 5k stall but I leave at 4200 off the trans brake.

Jim, I don't recall seeing any 60' times. How were they? I'm pretty sure you have tire spinning leaving that high. Also I'm old school and don't no much in the tuning world but I was wondering if you should of had another tune with the new converter.

93' LX hatch, 460 w/150 plate, TH400, 9" w/ 3.60 spool. Best (so far!) of [email protected] 146 mph with 1.40 spinning 60' on steel heads
Reese,
Been saying single digit coming for 3 years.....guess I finally made it!
stang93mustang is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1