Ford Mustang Forum - View Profile: ItalianM4fia
 

ItalianM4fia ItalianM4fia is offline

Apprentice

  Timeslip Database

Horsepower
0.0
60 foot time
0.000
1/8 Mile ET
0.000
1/8 Mile MPH
0.00
1/4 Mile ET
0.000
1/4 Mile MPH
0.00

  About Me

  • Member Info
    Real Name
    Kurt
    Location
    Chatham
    State or Province
    Ontario
    Country
    Canada
  • Timeslip Database
    Horsepower
    0.0
    60 foot time
    0.000
    1/8 Mile ET
    0.000
    1/8 Mile MPH
    0.00
    1/4 Mile ET
    0.000
    1/4 Mile MPH
    0.00
  • Signature
    87 LX 5.0L Hatch - MAF conversion/AFR165/224-230 .544-.544/Tubular GT40 Intake/BBK 70MM TB+BBK EGR spacer/19lbers/76MM BBK MAF/BBK unequal shorties+BBK catted X+Pypes Violators+3"tips/carbon fiber trac-loc/stage 2 racing clutch+17lbs flywheel/triple core rad/chromoly input shaft+chromoly 2nd&3rd gears+chromoly counter shaft+carbon fiber syncros/steel bearing retainer/more and more and more

  Statistics

General Information
  • Last Activity: 09-07-2017
  • Joined: 01-02-2011
  • Referrals: 0

  Friends

Showing Friends 1 to 1 of 1

  Mentions

No results to display...

  Quotes

08-25-2015
01:41 PM - ItalianM4fia quoted mhuggler in post Annoying idle again
I used the plate and it didn'...
12:36 PM - ItalianM4fia quoted squekster in post Annoying idle again
Did you adjust the restrictor....
12:27 PM - squekster quoted ItalianM4fia in post Annoying idle again
Nope throttle cable or TB isn't s...
12:09 PM - ItalianM4fia quoted Urambo Tauro in post Annoying idle again
How about the throttle cable? ...
08-24-2015
07:32 PM - ItalianM4fia quoted Blt2Lst in post Annoying idle again
Are you getting any codes be...
07:13 AM - ItalianM4fia quoted theYman in post Annoying idle again
Have you done the 10 pin (sa...
06-17-2015
07:17 AM - ItalianM4fia quoted new8514 in post Sct eliminator help
I was trying to say in 3 hou...
06-16-2015
04:05 PM - ItalianM4fia quoted new8514 in post Sct eliminator help
I had my car tuned on a dyno...
05-29-2015
09:52 PM - ItalianM4fia quoted MarkS93 in post High engine temps
Hmmmm..I'm using the flexali...
04:03 PM - ItalianM4fia quoted MarkS93 in post High engine temps
There was another thread lik...
05-28-2015
04:54 PM - ItalianM4fia quoted squekster in post High engine temps
Take a look at this it might s...
04:32 PM - squekster quoted ItalianM4fia in post High engine temps
I've build my HCI engine and I'm ...
05-04-2015
08:26 AM - squekster quoted ItalianM4fia in post Clutch and heat?
Got only 2 issues with my build.....
05-03-2015
10:24 AM - 93mustang quoted ItalianM4fia in post Clutch and heat?
Ok I'll try a 185 but when I was ...
09:24 AM - 93mustang quoted ItalianM4fia in post Clutch and heat?
No I don't have under drive pulle...
 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1