Brake issue on 2016 Ecoboost - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 02-24-2017 Thread Starter
PONY Member
 
Nelsoncp21's Avatar
 
Joined: Dec 2016
Posts: 271
 
Garage
Brake issue on 2016 Ecoboost

I wanted to get some opinions from some more experienced mustang owners. I bought my 2.3L turbo in Aug with 4k miles on it. It was a dealer demo. I now have 13k miles on it and have noticed for the past month or so that when I first start and pull the vehicle out the brakes are squeaking then it goes away. I've also noticed when it's damp outside whether from rain or going through a car wash that the brakes stick a little at first. I mentioned all this to the dealership for them to investigate when I had the car in for maintenance this past weekend. The dealership said they checked the brakes and everything is fine. Said the squeaking might just be some light rust or buildup coming off when I first start out after sitting a few hours. No explanation for the sticking though.
To me this seems like BS as the vehicle is very young and should not be acting this way already. I commute around 70 miles round trip everyday mostly highway so I would think if anything the brakes would be in better condition then similar cars of the same mileage. Your thoughts?

Nelsoncp21 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-24-2017
Moderator
V6 Member
4.6L Member
5.0L Member
S197 Member
 
MustangLife's Avatar
 
Joined: Jan 2015
Location: North Carolina
Posts: 2,585
             
Garage
Quote:
Originally Posted by Nelsoncp21 View Post
I wanted to get some opinions from some more experienced mustang owners. I bought my 2.3L turbo in Aug with 4k miles on it. It was a dealer demo. I now have 13k miles on it and have noticed for the past month or so that when I first start and pull the vehicle out the brakes are squeaking then it goes away. I've also noticed when it's damp outside whether from rain or going through a car wash that the brakes stick a little at first. I mentioned all this to the dealership for them to investigate when I had the car in for maintenance this past weekend. The dealership said they checked the brakes and everything is fine. Said the squeaking might just be some light rust or buildup coming off when I first start out after sitting a few hours. No explanation for the sticking though.
To me this seems like BS as the vehicle is very young and should not be acting this way already. I commute around 70 miles round trip everyday mostly highway so I would think if anything the brakes would be in better condition then similar cars of the same mileage. Your thoughts?
I know this isn't what you want to hear, BUT it has to be said unfortunately... I am sure you may already know, but dealer loaner and dealer demo cars are much like rental cars they take one hell of a beating. So with that I am sure the brakes were used a good bit more in those 4K miles than one would think with normal personal ownership and driving habits. As almost every one of those 4K miles were people doing just what the car was in service for and that is demoing it to see just what the car could do since it is a sportscar. Demo cars are used by the dealers to sell cars. Then encourage people to beat on them and have fun so they can sell them the car when they get back to the dealership...

So with all that said I would check the pad life and see what that is as they could be near replacement. I would strongly doubt that it is near replacement as it only has 13K miles, but who knows. As far as sticking I know I had this issue right after I replaced my brakes and on my 06 GT you have to reset the brake piston. So maybe that needs adjustment/reseting not sure how it all works on newer cars and if the same. Does that car ever feel like the brakes are dragging after pulling away from lights? A good way to know is by smell or feeling your wheels after a long drive. If the wheels are hot then your brakes may be dragging. Park on a slight incline and have in natural does the car free roll easy?


Current Garage
(11.)2012 GT500 silver with red stripe, SVT performance package, and Recaro seats.
2018 Honda Civic Type R
Past Mustangs in order and color of text.
(1.)2000, (2.)2004, (3.)2006GT/Auto traded for (4.)2006GT/Manual, (5.)1996, (6.)2011GT, (7.)2003GT, (8.)2006GT, (9)2013 Boss 302, and (10.) 2002GT
(I have owned a few non Mustang cars over the years as well, but always try to have a Mustang with it or come quickly back to a Mustang!)
MustangLife is offline  
post #3 of 3 (permalink) Old 02-25-2017 Thread Starter
PONY Member
 
Nelsoncp21's Avatar
 
Joined: Dec 2016
Posts: 271
 
Garage
I'll check the pad level but it's only happening at low speed braking. It's not the wear indicator or anything as it only does it when braking at low speeds. Sounds like a large truck braking.
I'll try the hill test as you stated to see if it's sticking.
Nelsoncp21 is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1