97 A/C Please Help - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 07-04-2005 Thread Starter
Rookie
 
angel1964's Avatar
 
Joined: May 2005
Location: Memphis
Posts: 11
 
Angry 97 A/C Please Help

i have a ''97'' mustang and my air has stopped blowin' literally through my air vents, however, it WILL blow through the defrost and on the floor and its extremely cold and the temperture remains cold..

[ please advise me on whats going on with my air vent ]


angel1964 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-05-2005
2.3L Member
4.6L Member
5.0L Member
 
hotwheels's Avatar
 
Joined: Dec 2002
Posts: 398
 
i would check all your vacuum lines and look at the air intake box behind your glove box and make sure it is clean and moving freely....most of the vacuum supply lines will be on the passenger side firewall.......

hotwheels of insanemustangs

hotwheels is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C troubleshooting... Stangboy5666 5.0L Tech 24 08-10-2009 06:13 PM
Shaker controls the A/C? 7th Pny 2005-2010 Mustang GT Tech 12 09-14-2005 07:31 PM
Help with stuck A/C Heater switch dpellegr 5.0L Tech 2 07-02-2005 04:02 PM
Anyone had on-going A/C problems 99+ Mustangs? GTron 4.6L Talk 3 04-05-2005 10:01 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1