1999 Mustang V6 idle issue - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 01-07-2011 Thread Starter
Rookie
 
99allgonoshow99's Avatar
 
Joined: Jan 2011
Location: Chicago
Posts: 10
 
1999 Mustang V6 idle issue

My 99 revs to about 1.5 2k right when i put it in drive or reverse drives idles normal after though sometimes it feels like its gonna stall when i stop. like if u tried to come to a stop in a 5-speed w/o hittin the cluch feels like the tourqe conv wont let go but i dont think there related. the motor is an 03 long block stock with the 99 upper intake an other acc. i also just sprung an evap/intake leak code but its been doing the revving gear thing since the swap. Thanks

99allgonoshow99 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-07-2011
Apprentice
 
WhiteMustang562's Avatar
 
Joined: Jan 2011
Location: 562
Posts: 81
 
My car is the same it like wants to turn off when i make a hard stop like u letting the clutch out to fast. Does your motor knock? check out my Thread.


2002 Ford Mustang
V6 AT Stock
WhiteMustang562 is offline  
post #3 of 6 (permalink) Old 01-08-2011
Apprentice
Classic Member
 
fasterthenev's Avatar
 
Joined: Mar 2008
Location: Lorain
Posts: 241
 
tune up latley?
maybe an egr valve as those need to be replaced at 100,000 miles
my car stalled alot in the cold weather if i pushed in the clutch to fast coming to a stop then i did a tune up...
it still idles weird at times when coming to a stop.

1973 Mustang coup:(in progress)
New ginger interior
Rebuilt 302 and c4
Flowtech headers
2.5in exaust w/flowmaster 40's

2012 chrysler 200s (DD)
fasterthenev is offline  
 
post #4 of 6 (permalink) Old 01-09-2011
SHELBY GT 350 Member
 
wmburns's Avatar
 
Joined: Sep 2010
Location: Houston
Posts: 6,849
         
Quote:
Originally Posted by 99allgonoshow99 View Post
My 99 revs to about 1.5 2k right when i put it in drive or reverse drives idles normal after though sometimes it feels like its gonna stall when i stop. like if u tried to come to a stop in a 5-speed w/o hittin the cluch feels like the tourqe conv wont let go but i dont think there related. the motor is an 03 long block stock with the 99 upper intake an other acc. i also just sprung an evap/intake leak code but its been doing the revving gear thing since the swap. Thanks
One of the possible causes of slow idle especially when stopping is a lock up torque converter that is not releasing as it should.

One of the other causes of high idle is a vacuum leak after the throttle body. A leak in the intake manifold qualifies.

IMO, you should consider the possibility that the problems ARE related and the problem solution is right in your hand.

Does it have a delayed engagement in drive and reverse? What is the condtion of the fluid?

Regarding vacuum leaks, today's cars simply will not run right with even the smallest vacuum leak. I suspect that onced fixed, there will be a world of difference.

The link below has more information about how to troubleshoot IAC problems. In your case, it doesn't make sense to perform the steps as there is a known vacuum leak.

https://www.allfordmustangs.com/forum...ml#post2260649

2003 GT Convertible (sold & missed)
2000 GT coupe (Craigslist project. Fixed. Now my DD). Windsor to Romeo swap.
wmburns is offline  
post #5 of 6 (permalink) Old 01-09-2011 Thread Starter
Rookie
 
99allgonoshow99's Avatar
 
Joined: Jan 2011
Location: Chicago
Posts: 10
 
maybe i didnt tighten the intake down enough when i installed the motor i checked and rechecked the vac lines already. egr is new,plugs and tranny fluid too, i drained the TC when i pulled the motor so all the fluid is new. it is slow to engage when cold but i think thats normal. I,m gonna clean maybe replace IAC. Maybe the 99 intake isnt quite compatible with the 03 block??? anybody know? Its only been running for a month since the new engine
99allgonoshow99 is offline  
post #6 of 6 (permalink) Old 01-09-2011
SHELBY GT 350 Member
V6 Member
 
Markstang's Avatar
 
Joined: Jan 2009
Location: Dumont
Posts: 6,168
 
no, theyre pretty much identical from 99-04.. there are slight internal differences but overall theyre the same

2003 3.8L V6 4R70W
Windstar Upper Intake with cool-air intake, MAC LT headers, BBK O/R H-pipe, and flow 40s, SCT tuner, FRPP Alum. D/S, 3.73 gears, Auburn HP limited slip, and Team Z LCAs, Eibach sway bars.
Best 1/4 time: 15.036 @90.92mph, 2.148 60'
Markstang is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1