1995 Mustang Just shuts off - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 03-19-2011 Thread Starter
Rookie
 
pdriggers's Avatar
 
Joined: Mar 2011
Location: Walterboro
Posts: 1
 
Any Suggestions? 1995 Mustang Just shuts off

I have a 95 V6. When I crack the car, it will run for about 3 to 5 minutes and then just shuts off. I'm guessing that it's something to do with the fuel system b/c voltage is good. I already change the fuel regulator and that didn't correct the problem. Can anyone give me some advice on what else I can do to fix the problem. Thanks.

pdriggers is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-19-2011
Rookie
 
badenov's Avatar
 
Joined: Mar 2011
Location: northern NJ
Posts: 3
 
Not sure if this applies in your case but had a similar problem with my 99 4.6. Initially it died at a gas station with the anti-theft light flashing. Had it towed to a shop and they said it started just fine. They kept it a few days and said it reported a misfire, and replaced one of the ignition coils. It did not seem to me that this could have been the problem but it did fix an intermittent stutter during acceleration. One week later it started diyng at random even while driving, but would die for only a second or two, since the car was in gear. When idling it would just die. After another week at the shop they found it was a broken wire in the wiring harness under the battery tray. Had to do with broken communication between the ECM and the instrument panel which does the anti theft key validation.

badenov is offline  
post #3 of 6 (permalink) Old 03-20-2011
Apprentice
V6 Member
 
fordboy 3.8's Avatar
 
Joined: Nov 2010
Location: Louisville
Posts: 144
 
does all of your lights and everything stay on when it dies becasue if they do then i would think it might be the fuel pump going out on you
fordboy 3.8 is offline  
 
post #4 of 6 (permalink) Old 03-20-2011
Banned
4.6L Member
 
2Manystangs's Avatar
 
Joined: Mar 2009
Location: Tampa
Posts: 12,438
 
I'd second the ECU problem...it seems like the fuel pump, but they typically die once and stay dead.
2Manystangs is offline  
post #5 of 6 (permalink) Old 03-21-2011
Apprentice
V6 Member
 
project stang''s Avatar
 
Joined: Dec 2010
Location: plymouth
Posts: 55
 
i got the same problem with my 95 try a tune up and have them run a scan test for any trouble codes. if that doesnt help try the fuel filter, then the fuel pump thats wat i am doin but i ran out of money which sucks but anyway try that and let us know how it helps u so i can try wat u did..... that must be a common problem wit the 95. just to know is it a coupe or conv?
project stang' is offline  
post #6 of 6 (permalink) Old 03-23-2011
MACH I Member
V6 Member
5.0L Member
 
metalman302's Avatar
 
Joined: Dec 2010
Location: Phoenix
Posts: 2,907
 
Bad alternator and the alt light is burnt out? The alt light is a picture of a battery. It should be lit with key on, engine off.
metalman302 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
fuel problems , shuts off

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1