Please Help!! - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-04-2006 Thread Starter
 
por935's Avatar
 
Joined: Apr 2006
Posts: 3
 
Question Please Help!!

I bought a 94' Mustang V6 from my cousin. Did not pass emissions and it wasn't running real good, so I ran the codes. I replaced the MAF sensor, didn't help. Finally replace the O2's and codes are fine. Runs like crap especially when you first start off it misses, and coughs. I have changed, gas filter, plugs, oil, serviced tranny, did back pressure check for bad converters, and cleaned throttle body, and most emission items. I've be told it was anything from a sticky valve, to the coil pack. Still runs a little rich. I've been working on it for so long, I can't think straight. I know I've missed something simple. Anyone have any ideas?

por935 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-04-2006
GT Member
V6 Member
 
tex117's Avatar
 
Joined: Mar 2005
Location: San Marcos
Posts: 1,490
 
I think a sticky valve is the most probable problem. I had an 94 dodge ram v6 and it liked to cough, miss, or click off the start and for the first 5 minutes of driving, but after it warmed up it ran good.


2002 v6 manual, SSM P&P Heads, Comp Cam from SSM, and some other stuff full list in profile.
214 RWHP, 215 RWTQ :tongue

"The trouble with our liberal friends is not that they're ignorant; it's just that they know so much that isn't so"
-Ronald Reagan
tex117 is offline  
post #3 of 5 (permalink) Old 04-04-2006
SHELBY GT 500 Member
V6 Member
 
kscoyote's Avatar
 
Joined: Aug 2002
Location: Topeka
Posts: 11,432
 
Quote:
Originally Posted by por935
I bought a 94' Mustang V6 from my cousin. Did not pass emissions and it wasn't running real good, so I ran the codes. I replaced the MAF sensor, didn't help. Finally replace the O2's and codes are fine. Runs like crap especially when you first start off it misses, and coughs. I have changed, gas filter, plugs, oil, serviced tranny, did back pressure check for bad converters, and cleaned throttle body, and most emission items. I've be told it was anything from a sticky valve, to the coil pack. Still runs a little rich. I've been working on it for so long, I can't think straight. I know I've missed something simple. Anyone have any ideas?
How many miles are on the car?

2ndly, did he get the head gaskets replaced?

Woe to him who builds his palace by unrighteousness,his upper rooms by injustice,making his countrymen work for nothing...Does it make you a king to have more and more cedar?Did not your father have food and drink?He did what was right and just,so all went well with him. He defended the cause of the poor and needy,and so all went well...But your eyes and your heart are set only on dishonest gain,on shedding innocent blood and on oppression and extortion. Jer 22:13, 15-17
kscoyote is offline  
 
post #4 of 5 (permalink) Old 04-04-2006 Thread Starter
 
por935's Avatar
 
Joined: Apr 2006
Posts: 3
 
Please Help

It has 154,000, and yes the head gaskets were replaced.
por935 is offline  
post #5 of 5 (permalink) Old 04-05-2006
SHELBY GT 500 Member
V6 Member
 
kscoyote's Avatar
 
Joined: Aug 2002
Location: Topeka
Posts: 11,432
 
Quote:
Originally Posted by por935
It has 154,000, and yes the head gaskets were replaced.
Have you checked your injectors? If one or more is leaking, that would do it . . .

could be vavle guides, or rings . . . any smoke at start up?

Woe to him who builds his palace by unrighteousness,his upper rooms by injustice,making his countrymen work for nothing...Does it make you a king to have more and more cedar?Did not your father have food and drink?He did what was right and just,so all went well with him. He defended the cause of the poor and needy,and so all went well...But your eyes and your heart are set only on dishonest gain,on shedding innocent blood and on oppression and extortion. Jer 22:13, 15-17
kscoyote is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1